checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: f6f8da48a68128c440f206fab4fc9300aa2882a44c0399e98f0d93aa4daf7c98
4
- data.tar.gz: 37f431b740f81ff4446fa844dd38d2caac24191f27dea0175afae89e236c9670
3
+ metadata.gz: 0a4be06b794f7f8db5561187324dd8fe2e3a6b524abbbbe3ff011811b8162f48
4
+ data.tar.gz: a1ad0c91297d1c069ef52aba227629d8ea40f83c443411f3a39704272403760b
5
5
SHA512:
6
- metadata.gz: 7de2e6d1a9d8b9075e35544ab838e3342742db34c72f31bbbf01732803d7d4b41b1a375b4a2db38e5cf68e860bcb09e11c84bd6c065034c355dd3ce77958ac81
7
- data.tar.gz: ad32859b681c2db76fce59c84509510528c2e0b598cd21c047f0f7aa396a32e042ef8b5fd15b2abbeaefa83fe39b04c9072a248ad0c4945edcfc9fc6864fcb55
6
+ metadata.gz: edb989da3f65589daf1a61c2526056a920be939d3e7beb92fc664d12d8362c3f1800ff8bb40698f174a9f676da30692b2914dd0d089a517f89d49f0c897e2ba7
7
+ data.tar.gz: c790746426a7b1769f31dcf6e64866d0b929a575153328797d9879823b1cd1c0f5b558b62d56eb69f9f12420d678e49ac1abb4445c35d6f781ffe9077c4a07e9
data/README.md CHANGED
@@ -7,7 +7,7 @@ This is the common configuration for ruby-style checks by [Rubocop](https://gith
7
7
Add this line to your application's Gemfile under the `development` and `test` groups to include a specific version of this gem:
8
8
9
9
```ruby
10
- gem 'rubocopital', git: 'git@gitlab.ycdev.nl:youngcapital/rubocopital.git', tag: '0.5.1', require: false
10
+ gem 'rubocopital', '~> 0.5.1', require: false
11
11
```
12
12
13
13
And then execute:
data/lib/rubocopital/version.rb CHANGED
@@ -1,5 +1,5 @@
1
1
# frozen_string_literal: true
2
2
3
3
module Rubocopital
4
- VERSION = '0.5.1'
4
+ VERSION = "0.5.2"
5
5
end
data/rubocopital.gemspec CHANGED
@@ -1,43 +1,41 @@
1
1
# frozen_string_literal: true
2
2
3
- lib = File.expand_path('../lib', __FILE__)
3
+ lib = File.expand_path("../lib", __FILE__)
4
4
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
5
- require 'rubocopital/version'
5
+ require "rubocopital/version"
6
6
7
7
Gem::Specification.new do |spec|
8
- spec.name = 'rubocopital'
8
+ spec.name = "rubocopital"
9
9
spec.version = Rubocopital::VERSION
10
- spec.authors = ['Marcel Eeken']
11
- spec.email = ['m.eeken@youngcapital.nl']
10
+ spec.authors = ["Marcel Eeken", "Martijn Bleeker"]
11
+ spec.email = ["m.eeken@youngcapital.nl", "martijn@thebleacher.com"]
12
12
13
- spec.summary = 'Shared rubocop configuration'
14
- spec.description = 'We need to have a common configuration of ruby style,
15
- this gem hold that.'
16
- spec.homepage = 'https://github.com/youngcapital/rubocopital'
17
- spec.license = 'MIT'
13
+ spec.summary = "Shared rubocop configuration"
14
+ spec.description = "We need to have a common configuration of ruby style,
15
+ this gem hold that."
16
+ spec.homepage = "https://github.com/youngcapital/rubocopital"
17
+ spec.license = "MIT"
18
18
19
19
if spec.respond_to?(:metadata)
20
- spec.metadata['allowed_push_host'] = "https://rubygems.org"
21
-
22
- spec.metadata['hompeage_uri'] = spec.homepage
20
+ spec.metadata["hompeage_uri"] = spec.homepage
21
+ spec.metadata["source_code_uri"] = spec.homepage
22
+ spec.metadata["changelog_uri"] = "https://github.com/youngcapital/rubocopital/blob/master/CHANGELOG.md"
23
- spec.metadata['source_code_uri'] = spec.homepage
24
- spec.metadata['changelog_uri'] = 'https://github.com/youngcapital/rubocopital/blob/master/CHANGELOG.md'
25
23
else
26
- raise 'RubyGems 2.0 or newer is required to protect against ' \
27
- 'public gem pushes.'
24
+ raise "RubyGems 2.0 or newer is required to protect against " \
25
+ "public gem pushes."
28
26
end
29
27
30
28
spec.files = `git ls-files -z`.split("\x0").reject do |f|
31
29
f.match(%r{^(test|spec|features)/})
32
30
end
33
- spec.bindir = 'exe'
31
+ spec.bindir = "exe"
34
32
spec.executables = spec.files.grep(%r{^exe/}) { |f| File.basename(f) }
35
- spec.require_paths = ['lib']
33
+ spec.require_paths = ["lib"]
36
34
37
- spec.add_runtime_dependency 'rubocop', '~> 0.67.2'
35
+ spec.add_runtime_dependency "rubocop", "~> 0.67.2"
38
36
spec.add_runtime_dependency "rubocop-rspec", "1.32.0"
39
37
40
- spec.add_development_dependency 'bundler', '~> 1.15'
41
- spec.add_development_dependency 'rake', '~> 10.0'
42
- spec.add_development_dependency 'rspec', '~> 3.0'
38
+ spec.add_development_dependency "bundler"
39
+ spec.add_development_dependency "rake", "~> 10.0"
40
+ spec.add_development_dependency "rspec", "~> 3.0"
43
41
end
metadata CHANGED
@@ -1,10 +1,11 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: rubocopital
3
3
version: !ruby/object:Gem::Version
4
- version: 0.5.1
4
+ version: 0.5.2
5
5
platform: ruby
6
6
authors:
7
7
- Marcel Eeken
8
+ - Martijn Bleeker
8
9
autorequire:
9
10
bindir: exe
10
11
cert_chain: []
@@ -42,16 +43,16 @@ dependencies:
42
43
name: bundler
43
44
requirement: !ruby/object:Gem::Requirement
44
45
requirements:
45
- - - "~>"
46
+ - - ">="
46
47
- !ruby/object:Gem::Version
47
- version: '1.15'
48
+ version: '0'
48
49
type: :development
49
50
prerelease: false
50
51
version_requirements: !ruby/object:Gem::Requirement
51
52
requirements:
52
- - - "~>"
53
+ - - ">="
53
54
- !ruby/object:Gem::Version
54
- version: '1.15'
55
+ version: '0'
55
56
- !ruby/object:Gem::Dependency
56
57
name: rake
57
58
requirement: !ruby/object:Gem::Requirement
@@ -85,6 +86,7 @@ description: |-
85
86
this gem hold that.
86
87
email:
87
88
- m.eeken@youngcapital.nl
89
+ - martijn@thebleacher.com
88
90
executables: []
89
91
extensions: []
90
92
extra_rdoc_files: []
@@ -111,7 +113,6 @@ homepage: https://github.com/youngcapital/rubocopital
111
113
licenses:
112
114
- MIT
113
115
metadata:
114
- allowed_push_host: https://rubygems.org
115
116
hompeage_uri: https://github.com/youngcapital/rubocopital
116
117
source_code_uri: https://github.com/youngcapital/rubocopital
117
118
changelog_uri: https://github.com/youngcapital/rubocopital/blob/master/CHANGELOG.md
@@ -130,7 +131,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
130
131
- !ruby/object:Gem::Version
131
132
version: '0'
132
133
requirements: []
133
- rubygems_version: 3.0.3
134
+ rubygems_version: 3.0.6
134
135
signing_key:
135
136
specification_version: 4
136
137
summary: Shared rubocop configuration