checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 5d89500c784b448bee79b8f6dcbbdd6d52e690fe28eb6ddb6a4d918bec014f6e
4
- data.tar.gz: 8243b98b70951510ebdf4556c7861ff7e20a285264a1647339d6bc72bb78ef9a
3
+ metadata.gz: e3bd5b772c813ca055bb157f001f938e037c6751164289ffaad33a816094c984
4
+ data.tar.gz: e587870e976b82236d791cfb103f3e2e215b680296bac881ac573fc2f22e3f66
5
5
SHA512:
6
- metadata.gz: cf2051ce415f212e9b86ac84bcddcd76f8968d8511baabac421f2017610e09a803c9a0ad7bc769af75e07931e3085007ee61ab1bd098ba7354fd04dcbd050cca
7
- data.tar.gz: bbdca385be05e5331742f988154b08953fad7ae1c12ed18886c9e7e12d583f2dd35b538b69057e170afc26cea176caa78703e23d16e0a28b657a3b9eb6c0087e
6
+ metadata.gz: e453df4ddad4bec91db240d267ecf10df8a49efe65b9ce9f7610fd1370f830b0b525b8f7d47060405b1c00a7db7946acc0f03ad90c97599ccd07bd641a6dd7c4
7
+ data.tar.gz: d46bd906c8c0759c9a66e5cd94aa943ff33297f27d5de1c017a305c021c6b79a9f5febe9ad620ac06e91abfed713dc7fd4229d4109469540e6586386651aedc4
data/README.md CHANGED
@@ -88,12 +88,15 @@ RailsDrivers::Routes.load_driver_routes
88
88
89
89
### RSpec
90
90
91
- If you use RSpec, add these lines to your `spec/rails_helper.rb` or `spec/spec_helper.rb`:
91
+ If you use RSpec with FactoryBot, add these lines to your `spec/rails_helper.rb` or `spec/spec_helper.rb`:
92
92
93
93
```ruby
94
94
Dir[Rails.root.join("drivers/*/spec/support/*.rb")].each { |f| require f }
95
95
96
96
RSpec.configure do |config|
97
+ FactoryBot.definition_file_paths += Dir['drivers/*/spec/factories']
98
+ FactoryBot.reload
99
+
97
100
Dir[Rails.root.join('drivers/*/spec')].each { |x| config.project_source_dirs << x }
98
101
Dir[Rails.root.join('drivers/*/lib')].each { |x| config.project_source_dirs << x }
99
102
Dir[Rails.root.join('drivers/*/app')].each { |x| config.project_source_dirs << x }
data/lib/rails_drivers/version.rb CHANGED
@@ -1,5 +1,5 @@
1
1
# frozen_string_literal: true
2
2
3
3
module RailsDrivers
4
- VERSION = '0.3.1'
4
+ VERSION = '0.3.2'
5
5
end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: rails_drivers
3
3
version: !ruby/object:Gem::Version
4
- version: 0.3.1
4
+ version: 0.3.2
5
5
platform: ruby
6
6
authors:
7
7
- Nigel Baillie
8
8
autorequire:
9
9
bindir: bin
10
10
cert_chain: []
11
- date: 2019-12-20 00:00:00.000000000 Z
11
+ date: 2019-12-23 00:00:00.000000000 Z
12
12
dependencies:
13
13
- !ruby/object:Gem::Dependency
14
14
name: rails
@@ -39,6 +39,20 @@ dependencies:
39
39
- !ruby/object:Gem::Version
40
40
version: '0'
41
41
- !ruby/object:Gem::Dependency
42
+ name: rspec-rails
43
+ requirement: !ruby/object:Gem::Requirement
44
+ requirements:
45
+ - - ">="
46
+ - !ruby/object:Gem::Version
47
+ version: '0'
48
+ type: :development
49
+ prerelease: false
50
+ version_requirements: !ruby/object:Gem::Requirement
51
+ requirements:
52
+ - - ">="
53
+ - !ruby/object:Gem::Version
54
+ version: '0'
55
+ - !ruby/object:Gem::Dependency
42
56
name: sqlite3
43
57
requirement: !ruby/object:Gem::Requirement
44
58
requirements: