checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 1ca2866678aeb9e1e76fc1a4ce3538102fee2378802055306aca9e72701b6952
4
- data.tar.gz: 9b07a89a5d87c10b033110b769c6550ee01740f0240d7a462e9c3f28db032b34
3
+ metadata.gz: 00a4e94c41e76840f78918700ec33be3a4e2292457529cb8f657f2ab521a24fc
4
+ data.tar.gz: e1aa41e951fc8979ec522368c387af25d522d1a6b8b387da8312a1ba06947132
5
5
SHA512:
6
- metadata.gz: 14e6a65575cf3b79889eed8d917a334ad910d6795a18febde2df64cc6e20709ab67499d1dd466033d676c3b8aac5680f3a331ae27c86307f164cd409232b2f62
7
- data.tar.gz: 23d6d4cfd078b8b9e6a173099fac09adab5d810b6b9afc56eedc02f448ffae605417e3f1578af735a43cfda5bae15e335117f4752c3729699c404f587d996a1d
6
+ metadata.gz: c1c85cca3a1a0411950858c0385988c5066db86da95f33476da225971ea197f829fabe8bd21d98efae4808fa8cefd9fb8942b6fcbd154322f92c3a32cad5032e
7
+ data.tar.gz: dcdab6d92326de33bfe71d512b91d251be3a19da4e25b8ead325095474214474c7eb5ea526df10a649c8fdddf21bb1a887023853d5fb56dd761b8e9438ebb4b1
data/lib/gatekeeper.rb CHANGED
@@ -33,8 +33,8 @@ module Gatekeeper
33
33
#
34
34
# @return [Array<Symbol>] default allowed info names.
35
35
def default_allowed_info_names(user, model_class, &block)
36
- if @configuration.bypass_allowed_info.respond_to? :call
37
- bypassable = @configuration.bypass_allowed_info.call(user)
36
+ if configuration.bypass_allowed_info.respond_to? :call
37
+ bypassable = configuration.bypass_allowed_info.call(user)
38
38
else
39
39
bypassable = false
40
40
end
data/lib/gatekeeper/version.rb CHANGED
@@ -1,3 +1,3 @@
1
1
module Gatekeeper
2
- VERSION = '0.1.1'
2
+ VERSION = '0.1.3'
3
3
end
metadata CHANGED
@@ -1,29 +1,29 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: rails-mongoid-gatekeeper
3
3
version: !ruby/object:Gem::Version
4
- version: 0.1.1
4
+ version: 0.1.3
5
5
platform: ruby
6
6
authors:
7
7
- Francesco Ballardin
8
8
autorequire:
9
9
bindir: bin
10
10
cert_chain: []
11
- date: 2019-03-11 00:00:00.000000000 Z
11
+ date: 2019-11-08 00:00:00.000000000 Z
12
12
dependencies:
13
13
- !ruby/object:Gem::Dependency
14
14
name: rails
15
15
requirement: !ruby/object:Gem::Requirement
16
16
requirements:
17
- - - "~>"
17
+ - - ">="
18
18
- !ruby/object:Gem::Version
19
- version: 5.2.2
19
+ version: '0'
20
20
type: :runtime
21
21
prerelease: false
22
22
version_requirements: !ruby/object:Gem::Requirement
23
23
requirements:
24
- - - "~>"
24
+ - - ">="
25
25
- !ruby/object:Gem::Version
26
- version: 5.2.2
26
+ version: '0'
27
27
- !ruby/object:Gem::Dependency
28
28
name: mongoid
29
29
requirement: !ruby/object:Gem::Requirement
@@ -125,8 +125,7 @@ required_rubygems_version: !ruby/object:Gem::Requirement
125
125
- !ruby/object:Gem::Version
126
126
version: '0'
127
127
requirements: []
128
- rubyforge_project:
128
+ rubygems_version: 3.0.3
129
- rubygems_version: 2.7.6
130
129
signing_key:
131
130
specification_version: 4
132
131
summary: Provides various access control methods to models and controllers. To use