checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 7c5716d9529fecdda2007e2b10d2df7e7ed7b82a684121a799fdc69de901e378
4
- data.tar.gz: 1dde10f99eac937ca3c13fe6aa5657056ce43fc23438bbb9e9c97aadfd9dc697
3
+ metadata.gz: 4f5b250dcfe6e85b5a093e85115faa1275a0e42c8ea8befa20a876ceecabc564
4
+ data.tar.gz: 57baa4e9a4d52578a9f53f39fb56f3fb24365aabc7899f3cb4d8720bb8f23354
5
5
SHA512:
6
- metadata.gz: 4b4e3ab21a72855d4a42575ef7351b67db548a660220023e629ec993b7c82f1e21329f4af5f404f3696a60a87b5acf6c537653499ce848877e6c2f837435b909
7
- data.tar.gz: f3f8f054bfd7eed6bfe650e9cdabe63911127aeb6c830b9879079894eeff2027821e310681cf0e9383f0517dad4766bb7cecd6d59e9fba1ae23c2a0a1d9d14cf
6
+ metadata.gz: bfceddd95470e2f296543aff02ace0d33a4f4ec812004043609f09293a29d583f921ca307314f7f22357dfc1b43e64474d6308db1ce7171d622ac2ba4a6841a9
7
+ data.tar.gz: c8c5156a632a5bf28076dfef3df318ca36f4d4f46272057edf08609a12fe490db58e967942bf0d04363b693864a681a36747544dec0c5553883cf66fd5afff6b
data/Gemfile.lock CHANGED
@@ -1,9 +1,7 @@
1
1
PATH
2
2
remote: .
3
3
specs:
4
- pexels_api_client (0.1.2)
4
+ pexels_api_client (0.1.3)
5
- activesupport
6
- api-auth (~> 2.3.1)
7
5
flexirest (~> 1.8.6)
8
6
json (~> 2.2.0)
9
7
rest-client (~> 2.1.0)
@@ -19,7 +17,6 @@ GEM
19
17
zeitwerk (~> 2.2)
20
18
addressable (2.7.0)
21
19
public_suffix (>= 2.0.2, < 5.0)
22
- api-auth (2.3.1)
23
20
ast (2.4.0)
24
21
bump (0.8.0)
25
22
concurrent-ruby (1.1.5)
@@ -50,17 +47,12 @@ GEM
50
47
minitest (5.13.0)
51
48
multi_json (1.14.1)
52
49
multipart-post (2.1.1)
53
- mustermann (1.0.3)
54
50
netrc (0.11.0)
55
51
parallel (1.19.1)
56
52
parser (2.6.5.0)
57
53
ast (~> 2.4.0)
58
54
public_suffix (4.0.1)
59
- rack (2.0.7)
60
- rack-protection (2.0.7)
61
- rack
62
55
rainbow (3.0.0)
63
- rake (10.5.0)
64
56
rest-client (2.1.0)
65
57
http-accept (>= 1.7.0, < 2.0)
66
58
http-cookie (>= 1.0.2, < 2.0)
@@ -88,13 +80,7 @@ GEM
88
80
unicode-display_width (>= 1.4.0, < 1.7)
89
81
ruby-progressbar (1.10.1)
90
82
safe_yaml (1.0.5)
91
- sinatra (2.0.7)
92
- mustermann (~> 1.0)
93
- rack (~> 2.0)
94
- rack-protection (= 2.0.7)
95
- tilt (~> 2.0)
96
83
thread_safe (0.3.6)
97
- tilt (2.0.10)
98
84
tzinfo (1.2.5)
99
85
thread_safe (~> 0.1)
100
86
unf (0.1.4)
@@ -115,10 +101,8 @@ DEPENDENCIES
115
101
bump (~> 0.8.0)
116
102
bundler (~> 2.0)
117
103
pexels_api_client!
118
- rake (~> 10.0)
119
104
rspec (~> 3.9.0)
120
105
rubocop (~> 0.77.0)
121
- sinatra (~> 2.0.7)
122
106
vcr (~> 5.0.0)
123
107
webmock (~> 3.7.6)
124
108
data/lib/pexels_api_client/version.rb CHANGED
@@ -1,5 +1,5 @@
1
1
# frozen_string_literal: true
2
2
3
3
module PexelsApiClient
4
- VERSION = '0.1.2'
4
+ VERSION = '0.1.3'
5
5
end
data/pexels_api_client.gemspec CHANGED
@@ -30,18 +30,14 @@ Gem::Specification.new do |spec|
30
30
spec.require_paths = ['lib']
31
31
spec.required_ruby_version = '~> 2.6.3'
32
32
33
- spec.add_runtime_dependency 'activesupport'
34
- spec.add_runtime_dependency 'api-auth', '~> 2.3.1'
35
33
spec.add_runtime_dependency 'flexirest', '~> 1.8.6'
36
34
spec.add_runtime_dependency 'json', '~> 2.2.0'
37
35
spec.add_runtime_dependency 'rest-client', '~> 2.1.0'
38
36
39
37
spec.add_development_dependency 'bump', '~> 0.8.0'
40
38
spec.add_development_dependency 'bundler', '~> 2.0'
41
- spec.add_development_dependency 'rake', '~> 10.0'
42
39
spec.add_development_dependency 'rspec', '~> 3.9.0'
43
40
spec.add_development_dependency 'rubocop', '~> 0.77.0'
44
- spec.add_development_dependency 'sinatra', '~> 2.0.7'
45
41
spec.add_development_dependency 'vcr', '~> 5.0.0'
46
42
spec.add_development_dependency 'webmock', '~> 3.7.6'
47
43
end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: pexels_api_client
3
3
version: !ruby/object:Gem::Version
4
- version: 0.1.2
4
+ version: 0.1.3
5
5
platform: ruby
6
6
authors:
7
7
- Nora Gabriela Alvarado
@@ -11,34 +11,6 @@ cert_chain: []
11
11
date: 2019-12-02 00:00:00.000000000 Z
12
12
dependencies:
13
13
- !ruby/object:Gem::Dependency
14
- name: activesupport
15
- requirement: !ruby/object:Gem::Requirement
16
- requirements:
17
- - - ">="
18
- - !ruby/object:Gem::Version
19
- version: '0'
20
- type: :runtime
21
- prerelease: false
22
- version_requirements: !ruby/object:Gem::Requirement
23
- requirements:
24
- - - ">="
25
- - !ruby/object:Gem::Version
26
- version: '0'
27
- - !ruby/object:Gem::Dependency
28
- name: api-auth
29
- requirement: !ruby/object:Gem::Requirement
30
- requirements:
31
- - - "~>"
32
- - !ruby/object:Gem::Version
33
- version: 2.3.1
34
- type: :runtime
35
- prerelease: false
36
- version_requirements: !ruby/object:Gem::Requirement
37
- requirements:
38
- - - "~>"
39
- - !ruby/object:Gem::Version
40
- version: 2.3.1
41
- - !ruby/object:Gem::Dependency
42
14
name: flexirest
43
15
requirement: !ruby/object:Gem::Requirement
44
16
requirements:
@@ -109,20 +81,6 @@ dependencies:
109
81
- !ruby/object:Gem::Version
110
82
version: '2.0'
111
83
- !ruby/object:Gem::Dependency
112
- name: rake
113
- requirement: !ruby/object:Gem::Requirement
114
- requirements:
115
- - - "~>"
116
- - !ruby/object:Gem::Version
117
- version: '10.0'
118
- type: :development
119
- prerelease: false
120
- version_requirements: !ruby/object:Gem::Requirement
121
- requirements:
122
- - - "~>"
123
- - !ruby/object:Gem::Version
124
- version: '10.0'
125
- - !ruby/object:Gem::Dependency
126
84
name: rspec
127
85
requirement: !ruby/object:Gem::Requirement
128
86
requirements:
@@ -151,20 +109,6 @@ dependencies:
151
109
- !ruby/object:Gem::Version
152
110
version: 0.77.0
153
111
- !ruby/object:Gem::Dependency
154
- name: sinatra
155
- requirement: !ruby/object:Gem::Requirement
156
- requirements:
157
- - - "~>"
158
- - !ruby/object:Gem::Version
159
- version: 2.0.7
160
- type: :development
161
- prerelease: false
162
- version_requirements: !ruby/object:Gem::Requirement
163
- requirements:
164
- - - "~>"
165
- - !ruby/object:Gem::Version
166
- version: 2.0.7
167
- - !ruby/object:Gem::Dependency
168
112
name: vcr
169
113
requirement: !ruby/object:Gem::Requirement
170
114
requirements: