checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA1:
3
- metadata.gz: 218508fbabc682014853065308c51db130593dfb
4
- data.tar.gz: 356462e4cfb0b8b6532613c0972fd11a8a4363b6
3
+ metadata.gz: 267c48cbc01616267240dda45dad7fb41f60acd8
4
+ data.tar.gz: 3d0017596678b2ec30fe058ff0b99022deeb7305
5
5
SHA512:
6
- metadata.gz: 44505c0684395214fb9ba940ef4a033b53aaf3419c9ff99f2d25be7119eea6755fd9e0fa815137c34c99fab6deee361af0a4c9f28b018b358fc2576d94c727a0
7
- data.tar.gz: 2dea6475eabf7a4e44efed4f56ed1c25063aa723997fe4acf39c50b5141b40843dc9e7ffcae808a5802e260ac3747d84056506fec4efd3967e494d8a9caae193
6
+ metadata.gz: 813ecf6f4517829ba91101fd6c275ec7541910aa343a1b49cde9ac83991a56c37a7fd25fb064f62cddd29ddf90303cd73122eb587b17a31fd6efc6b6b60d5d5a
7
+ data.tar.gz: bf0d9bc8fc038b8c933f1785b98bb5b9ae3e29f0dbbe7253d39293205cc80c7c122d8ac865425b651efaa4f5078765bcbec5bc03b7dd899d76b0402af4db6b72
data/.github/ISSUE_TEMPLATE/bug_report.md CHANGED
@@ -10,9 +10,9 @@ A clear and concise description of what the bug is.
10
10
**To Reproduce**
11
11
Steps to reproduce the behavior:
12
12
1. Go to '...'
13
- 2. Click on '....'
14
- 3. Scroll down to '....'
15
- 4. See error
13
+ 2. Create a new project or clone one from '...'
14
+ 3. Add gem
15
+ 4. Bundle/Run/Test/...
16
16
17
17
**Expected behavior**
18
18
A clear and concise description of what you expected to happen.
@@ -20,16 +20,13 @@ A clear and concise description of what you expected to happen.
20
20
**Screenshots**
21
21
If applicable, add screenshots to help explain your problem.
22
22
23
- **Desktop (please complete the following information):**
24
- - OS: [e.g. iOS]
25
- - Browser [e.g. chrome, safari]
26
- - Version [e.g. 22]
27
-
28
- **Smartphone (please complete the following information):**
29
- - Device: [e.g. iPhone6]
23
+ **Environment:**
24
+ - OS name and version
25
+ - Ruby manager name and version (if present)
26
+ - Ruby version
27
+ - Bundler version
28
+ - Jekyll version
29
+ - Jekyll Favicon version
30
- - OS: [e.g. iOS8.1]
31
- - Browser [e.g. stock browser, safari]
32
- - Version [e.g. 22]
33
30
34
31
**Additional context**
35
32
Add any other context about the problem here.
data/.github/PULL_REQUEST_TEMPLATE.md CHANGED
@@ -1,14 +1,16 @@
1
1
# PR Template
2
2
3
- Include at least this concepts:
3
+ - Tell us...
4
+ - what you wanted to achieve
5
+ - how you did it (use Markdown and screenshots if needed)
4
6
5
- - Explain what you wanted to achieve
7
+ - Did you...
8
+ - [ ] update the Readme? (if needed)
9
+ - [ ] update the Changelog? (if needed)
10
+ - [ ] update the tests?
11
+ - [ ] run the tests?
12
+ - [ ] check rubocop?
6
13
7
- - Explain what you did
14
+ Don't forget to visit [travis-ci](https://travis-ci.org/afaundez/jekyll-favicon/pull_requests) after creating the PR.
8
15
9
- - use markdown
16
+ Thanks for contributing!
10
- - include screenshots if helps to explain
11
-
12
- - Explain how to test it
13
-
14
- Thanks for contrubuting!
data/.travis.yml CHANGED
@@ -1,9 +1,9 @@
1
1
sudo: false
2
2
language: ruby
3
3
rvm:
4
- - 2.6.0
5
- - 2.5.3
6
- - 2.4.5
4
+ - 2.6.4
5
+ - 2.5.6
6
+ - 2.4.7
7
7
- 2.3.8
8
8
- 2.2.10
9
9
- 2.1.10
data/CHANGELOG.md CHANGED
@@ -6,6 +6,11 @@ and this project adheres to [Semantic Versioning](http://semver.org/spec/v2.0.0.
6
6
7
7
## [Unreleased]
8
8
9
+ ## [0.2.8] - 2019-09-11
10
+ ### Changed
11
+ - Upgrade mini_magick 4.9.4 in gemspec for security fix
12
+ - Update gemspec to support Jekyll 4.0
13
+
9
14
## [0.2.7] - 2019-05-27
10
15
### Fixed
11
16
- Set default background back to none
data/Gemfile.lock CHANGED
@@ -1,15 +1,15 @@
1
1
PATH
2
2
remote: .
3
3
specs:
4
- jekyll-favicon (0.2.7)
5
- jekyll (~> 3.0)
6
- mini_magick (~> 4.5)
4
+ jekyll-favicon (0.2.8)
5
+ jekyll (>= 3.0, < 5.0)
6
+ mini_magick (>= 4.9.4)
7
7
8
8
GEM
9
9
remote: https://rubygems.org/
10
10
specs:
11
- addressable (2.6.0)
12
- public_suffix (>= 2.0.2, < 4.0)
11
+ addressable (2.7.0)
12
+ public_suffix (>= 2.0.2, < 5.0)
13
13
ast (2.4.0)
14
14
colorator (1.1.0)
15
15
concurrent-ruby (1.1.5)
@@ -22,7 +22,7 @@ GEM
22
22
http_parser.rb (0.6.0)
23
23
i18n (0.9.5)
24
24
concurrent-ruby (~> 1.0)
25
- jekyll (3.8.5)
25
+ jekyll (3.8.6)
26
26
addressable (~> 2.4)
27
27
colorator (~> 1.0)
28
28
em-websocket (~> 0.5)
@@ -45,26 +45,26 @@ GEM
45
45
rb-fsevent (~> 0.9, >= 0.9.4)
46
46
rb-inotify (~> 0.9, >= 0.9.7)
47
47
mercenary (0.3.6)
48
- mini_magick (4.9.3)
49
- mini_portile2 (2.3.0)
48
+ mini_magick (4.9.5)
49
+ mini_portile2 (2.4.0)
50
50
minitest (5.11.3)
51
51
minitest-hooks (1.5.0)
52
52
minitest (> 5.3)
53
- nokogiri (1.8.5)
54
- mini_portile2 (~> 2.3.0)
55
- parallel (1.12.1)
56
- parser (2.5.1.2)
53
+ nokogiri (1.9.1)
54
+ mini_portile2 (~> 2.4.0)
55
+ parallel (1.13.0)
56
+ parser (2.6.4.0)
57
57
ast (~> 2.4.0)
58
58
pathutil (0.16.2)
59
59
forwardable-extended (~> 2.6)
60
60
powerpack (0.1.2)
61
- public_suffix (3.0.3)
61
+ public_suffix (3.1.1)
62
62
rainbow (3.0.0)
63
63
rake (10.5.0)
64
64
rb-fsevent (0.10.3)
65
65
rb-inotify (0.9.10)
66
66
ffi (>= 0.5.0, < 2)
67
- rouge (3.3.0)
67
+ rouge (3.10.0)
68
68
rubocop (0.54.0)
69
69
parallel (~> 1.10)
70
70
parser (>= 2.5)
@@ -72,20 +72,20 @@ GEM
72
72
rainbow (>= 2.2.2, < 4.0)
73
73
ruby-progressbar (~> 1.7)
74
74
unicode-display_width (~> 1.0, >= 1.0.1)
75
- ruby-progressbar (1.10.0)
75
+ ruby-progressbar (1.10.1)
76
76
safe_yaml (1.0.5)
77
77
sass (3.7.4)
78
78
sass-listen (~> 4.0.0)
79
79
sass-listen (4.0.0)
80
80
rb-fsevent (~> 0.9, >= 0.9.4)
81
81
rb-inotify (~> 0.9, >= 0.9.7)
82
- unicode-display_width (1.4.0)
82
+ unicode-display_width (1.6.0)
83
83
84
84
PLATFORMS
85
85
ruby
86
86
87
87
DEPENDENCIES
88
- bundler (~> 1.16)
88
+ bundler (~> 1.17)
89
89
jekyll-favicon!
90
90
minitest (~> 5.0)
91
91
minitest-hooks (~> 1.4, >= 1.4.2)
data/README.md CHANGED
@@ -41,7 +41,7 @@ sudo apt install librsvg2-bin
41
41
Add this line to your application's Gemfile:
42
42
43
43
```ruby
44
- gem 'jekyll-favicon', '~> 0.2.7', group: :jekyll_plugins
44
+ gem 'jekyll-favicon', '~> 0.2.8', group: :jekyll_plugins
45
45
```
46
46
47
47
## Usage
data/jekyll-favicon.gemspec CHANGED
@@ -24,13 +24,13 @@ Gem::Specification.new do |spec|
24
24
25
25
spec.required_ruby_version = '>= 2.1.0'
26
26
27
- spec.add_development_dependency 'bundler', '~> 1.16'
27
+ spec.add_development_dependency 'bundler', '~> 1.17'
28
28
spec.add_development_dependency 'minitest', '~> 5.0'
29
29
spec.add_development_dependency 'minitest-hooks', '~> 1.4', '>= 1.4.2'
30
30
spec.add_development_dependency 'nokogiri', '~> 1.8'
31
31
spec.add_development_dependency 'rake', '~> 10.0'
32
32
spec.add_development_dependency 'rubocop', '~> 0.54.0', '>= 0.54.0'
33
33
34
- spec.add_runtime_dependency 'jekyll', '~> 3.0'
35
- spec.add_runtime_dependency 'mini_magick', '~> 4.5'
34
+ spec.add_runtime_dependency 'jekyll', '>= 3.0', '< 5.0'
35
+ spec.add_runtime_dependency 'mini_magick', '>= 4.9.4'
36
36
end
data/lib/jekyll/favicon/version.rb CHANGED
@@ -1,5 +1,5 @@
1
1
module Jekyll
2
2
module Favicon
3
- VERSION = '0.2.7'.freeze
3
+ VERSION = '0.2.8'.freeze
4
4
end
5
5
end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: jekyll-favicon
3
3
version: !ruby/object:Gem::Version
4
- version: 0.2.7
4
+ version: 0.2.8
5
5
platform: ruby
6
6
authors:
7
7
- Alvaro Faundez
8
8
autorequire:
9
9
bindir: exe
10
10
cert_chain: []
11
- date: 2019-05-27 00:00:00.000000000 Z
11
+ date: 2019-09-11 00:00:00.000000000 Z
12
12
dependencies:
13
13
- !ruby/object:Gem::Dependency
14
14
name: bundler
@@ -16,14 +16,14 @@ dependencies:
16
16
requirements:
17
17
- - "~>"
18
18
- !ruby/object:Gem::Version
19
- version: '1.16'
19
+ version: '1.17'
20
20
type: :development
21
21
prerelease: false
22
22
version_requirements: !ruby/object:Gem::Requirement
23
23
requirements:
24
24
- - "~>"
25
25
- !ruby/object:Gem::Version
26
- version: '1.16'
26
+ version: '1.17'
27
27
- !ruby/object:Gem::Dependency
28
28
name: minitest
29
29
requirement: !ruby/object:Gem::Requirement
@@ -110,30 +110,36 @@ dependencies:
110
110
name: jekyll
111
111
requirement: !ruby/object:Gem::Requirement
112
112
requirements:
113
- - - "~>"
113
+ - - ">="
114
114
- !ruby/object:Gem::Version
115
115
version: '3.0'
116
+ - - "<"
117
+ - !ruby/object:Gem::Version
118
+ version: '5.0'
116
119
type: :runtime
117
120
prerelease: false
118
121
version_requirements: !ruby/object:Gem::Requirement
119
122
requirements:
120
- - - "~>"
123
+ - - ">="
121
124
- !ruby/object:Gem::Version
122
125
version: '3.0'
126
+ - - "<"
127
+ - !ruby/object:Gem::Version
128
+ version: '5.0'
123
129
- !ruby/object:Gem::Dependency
124
130
name: mini_magick
125
131
requirement: !ruby/object:Gem::Requirement
126
132
requirements:
127
- - - "~>"
133
+ - - ">="
128
134
- !ruby/object:Gem::Version
129
- version: '4.5'
135
+ version: 4.9.4
130
136
type: :runtime
131
137
prerelease: false
132
138
version_requirements: !ruby/object:Gem::Requirement
133
139
requirements:
134
- - - "~>"
140
+ - - ">="
135
141
- !ruby/object:Gem::Version
136
- version: '4.5'
142
+ version: 4.9.4
137
143
description: Jekyll-favicon is a jekyll plugin that adds the tag favicon, generating
138
144
html tags for favicon.
139
145
email: