checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 0451e0d4dca3b9dc06d00238a954f85785a5d22ddc1152eec280a0232b114ef3
4
- data.tar.gz: ecd2f7224e7498e9cb21efc75ff8b1fb0f745ad8b6fc749cee68e3d11b921c4e
3
+ metadata.gz: 54a94804a69989dd08e829b41452a0c51c3640cfb0854c31ffd04005f1cf4f7c
4
+ data.tar.gz: 97254ece0d99e61b15be1a7d4e03e632223d0640db204fad36ec9f80d05560c2
5
5
SHA512:
6
- metadata.gz: 913273f23abb4115d12a5989afd1acf6efbf4a96cf4349c118df2b6e746ecd4abaa575b55058e25bbe4ff8624d02cb8a72ceaed8e08846eb742425f70d00c808
7
- data.tar.gz: 38221ef02935867890bdd3f494888c235861928103febd5605bda1fd280e5fc390ef14a8568fd9e9a515456aba70ccd73662ac529512aa2f6d5361cf6e7e2428
6
+ metadata.gz: e9f1bf2c6124d3d36658a43c56c86176c881b28cdb24d3c2a6103282080ebc638f96f044b6400131458fde1bde4f4bc897cb6ed3c73e3e4f7e726fc1cfbc2479
7
+ data.tar.gz: f8c2238541fc5947820307e02edc7e5a480188ce3e50ca9a5ad59031c5c860168edf849b8006e6563e03bbb426ea3da8f2d53b8064f57978ffe5e751b856cded
data/Gemfile.lock DELETED
@@ -1,73 +0,0 @@
1
- PATH
2
- remote: .
3
- specs:
4
- gem_codebreaker_amidasd (0.1.6)
5
-
6
- GEM
7
- remote: https://rubygems.org/
8
- specs:
9
- ast (2.4.0)
10
- coderay (1.1.2)
11
- colorize (0.8.1)
12
- diff-lcs (1.3)
13
- docile (1.3.2)
14
- fasterer (0.5.1)
15
- colorize (~> 0.7)
16
- ruby_parser (>= 3.13.0)
17
- jaro_winkler (1.5.3)
18
- json (2.2.0)
19
- method_source (0.9.2)
20
- parallel (1.17.0)
21
- parser (2.6.3.0)
22
- ast (~> 2.4.0)
23
- pry (0.12.2)
24
- coderay (~> 1.1.0)
25
- method_source (~> 0.9.0)
26
- rainbow (3.0.0)
27
- rake (10.5.0)
28
- rspec (3.8.0)
29
- rspec-core (~> 3.8.0)
30
- rspec-expectations (~> 3.8.0)
31
- rspec-mocks (~> 3.8.0)
32
- rspec-core (3.8.2)
33
- rspec-support (~> 3.8.0)
34
- rspec-expectations (3.8.4)
35
- diff-lcs (>= 1.2.0, < 2.0)
36
- rspec-support (~> 3.8.0)
37
- rspec-mocks (3.8.1)
38
- diff-lcs (>= 1.2.0, < 2.0)
39
- rspec-support (~> 3.8.0)
40
- rspec-support (3.8.2)
41
- rubocop (0.69.0)
42
- jaro_winkler (~> 1.5.1)
43
- parallel (~> 1.10)
44
- parser (>= 2.6)
45
- rainbow (>= 2.2.2, < 4.0)
46
- ruby-progressbar (~> 1.7)
47
- unicode-display_width (>= 1.4.0, < 1.7)
48
- ruby-progressbar (1.10.1)
49
- ruby_parser (3.13.1)
50
- sexp_processor (~> 4.9)
51
- sexp_processor (4.12.1)
52
- simplecov (0.16.1)
53
- docile (~> 1.1)
54
- json (>= 1.8, < 3)
55
- simplecov-html (~> 0.10.0)
56
- simplecov-html (0.10.2)
57
- unicode-display_width (1.6.0)
58
-
59
- PLATFORMS
60
- ruby
61
-
62
- DEPENDENCIES
63
- bundler (~> 2.0)
64
- fasterer (~> 0.5.1)
65
- gem_codebreaker_amidasd!
66
- pry (~> 0.12.2)
67
- rake (~> 10.0)
68
- rspec (~> 3.8)
69
- rubocop (~> 0.69.0)
70
- simplecov (~> 0.16.1)
71
-
72
- BUNDLED WITH
73
- 2.0.2
data/gem_codebreaker_amidasd-0.1.6.gem ADDED
Binary file
data/lib/gem_codebreaker_amidasd.rb CHANGED
@@ -3,5 +3,5 @@ require 'gem_codebreaker_amidasd/db_utility'
3
3
require 'gem_codebreaker_amidasd/user'
4
4
require 'gem_codebreaker_amidasd/game'
5
5
require 'gem_codebreaker_amidasd/statistic'
6
- module Codebreaker
6
+ module GemCodebreakerAmidasdGemCodebreakerAmidasd
7
7
end
data/lib/gem_codebreaker_amidasd/game.rb CHANGED
@@ -80,9 +80,10 @@ module GemCodebreakerAmidasd
80
80
del_index = []
81
81
@secret_code.each_with_index do |val, index|
82
82
del_index << index if val == input_code[index]
83
- @count_plus += 1
83
+ @count_plus += 1 if val == input_code[index]
84
84
end
85
- del_index.each do |index|
85
+
86
+ del_index.reverse.each do |index|
86
87
input_code.delete_at(index)
87
88
cache_secret_code.delete_at(index)
88
89
end
data/lib/gem_codebreaker_amidasd/version.rb CHANGED
@@ -1,3 +1,3 @@
1
1
module GemCodebreakerAmidasd
2
- VERSION = '0.1.6'.freeze
2
+ VERSION = '0.1.7'.freeze
3
3
end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: gem_codebreaker_amidasd
3
3
version: !ruby/object:Gem::Version
4
- version: 0.1.6
4
+ version: 0.1.7
5
5
platform: ruby
6
6
authors:
7
7
- Amidasd
8
8
autorequire:
9
9
bindir: exe
10
10
cert_chain: []
11
- date: 2019-08-15 00:00:00.000000000 Z
11
+ date: 2019-08-16 00:00:00.000000000 Z
12
12
dependencies:
13
13
- !ruby/object:Gem::Dependency
14
14
name: bundler
@@ -122,7 +122,6 @@ files:
122
122
- ".travis.yml"
123
123
- CODE_OF_CONDUCT.md
124
124
- Gemfile
125
- - Gemfile.lock
126
125
- LICENSE.txt
127
126
- README.md
128
127
- Rakefile
@@ -135,6 +134,7 @@ files:
135
134
- gem_codebreaker_amidasd-0.1.3.gem
136
135
- gem_codebreaker_amidasd-0.1.4.gem
137
136
- gem_codebreaker_amidasd-0.1.5.gem
137
+ - gem_codebreaker_amidasd-0.1.6.gem
138
138
- gem_codebreaker_amidasd.gemspec
139
139
- lib/gem_codebreaker_amidasd.rb
140
140
- lib/gem_codebreaker_amidasd/db_utility.rb
@@ -161,7 +161,8 @@ required_rubygems_version: !ruby/object:Gem::Requirement
161
161
- !ruby/object:Gem::Version
162
162
version: '0'
163
163
requirements: []
164
- rubygems_version: 3.0.4
164
+ rubyforge_project:
165
+ rubygems_version: 2.7.9
165
166
signing_key:
166
167
specification_version: 4
167
168
summary: Codebreaker game