checksums.yaml ADDED
@@ -0,0 +1,7 @@
1
+ ---
2
+ SHA256:
3
+ metadata.gz: 3b3d8890e6844a79464767d236abf56bc79bc042b7cc326cc8b02b9ec5930c42
4
+ data.tar.gz: 36a5cbf1b5858ec4f0c8c751c6dd1cbc5f7287ba8aebb793104f824f87e73950
5
+ SHA512:
6
+ metadata.gz: 9d6580e6e8fa3af28e4432bc2f6614ecdc08547f73c30892056edec9c689157ca50425cadaf8281fa2cc546526318f3cb0c679d0a8d7718f390e76cb1f944f1b
7
+ data.tar.gz: 1dac51c82eee0325daaf8708bb867e28346c78a31c6438d5dccced7cc48e24390d6d381d57799527f97e4e4b3c04793075efe1fb4372560fd575bcfab7600d0d
data/.travis.yml CHANGED
@@ -1,9 +1,6 @@
1
1
language: ruby
2
2
rvm:
3
- - 1.9.3
4
- - 1.9.2
5
- - ruby-head
6
- - jruby-19mode
3
+ - 2.6.5
4
+ - 2.5.7
5
+ - 2.4.9
6
+ - jruby
7
- - jruby-head
8
- - rbx-19mode
9
-
data/CHANGELOG.md CHANGED
@@ -1,3 +1,7 @@
1
+ 0.0.3
2
+
3
+ - Give bundler a chance to require this gem when listed in Gemfile
4
+
1
5
0.0.2
2
6
3
7
- Initialize backoff with Array or Range as a convenience.
data/Rakefile CHANGED
@@ -1,4 +1,5 @@
1
1
#!/usr/bin/env rake
2
+
2
3
require "bundler/gem_tasks"
3
4
require "rake/testtask"
4
5
data/exponential-backoff.gemspec CHANGED
@@ -13,6 +13,7 @@ Gem::Specification.new do |gem|
13
13
gem.name = "exponential-backoff"
14
14
gem.require_paths = ["lib"]
15
15
gem.version = ExponentialBackoff::VERSION
16
-
16
+
17
17
gem.add_development_dependency 'rake'
18
+ gem.add_development_dependency 'test-unit'
18
19
end
data/lib/exponential/backoff.rb ADDED
@@ -0,0 +1 @@
1
+ require 'exponential_backoff'
data/lib/exponential_backoff/version.rb CHANGED
@@ -1,3 +1,3 @@
1
1
class ExponentialBackoff
2
- VERSION = "0.0.2"
2
+ VERSION = "0.0.3"
3
3
end
data/test/exponential_backoff_test.rb CHANGED
@@ -14,7 +14,7 @@ class ExponentialBackoffTest < Test::Unit::TestCase
14
14
15
15
def test_no_maximal_time
16
16
assert_raise ArgumentError do
17
- backoff = ExponentialBackoff.new(2)
17
+ ExponentialBackoff.new(2)
18
18
end
19
19
end
20
20
metadata CHANGED
@@ -1,32 +1,43 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: exponential-backoff
3
3
version: !ruby/object:Gem::Version
4
- prerelease:
4
+ version: 0.0.3
5
- version: 0.0.2
6
5
platform: ruby
7
6
authors:
8
7
- Paweł Pacana
9
8
autorequire:
10
9
bindir: bin
11
10
cert_chain: []
12
- date: 2013-01-02 00:00:00.000000000 Z
11
+ date: 2019-11-08 00:00:00.000000000 Z
13
12
dependencies:
14
13
- !ruby/object:Gem::Dependency
15
- version_requirements: !ruby/object:Gem::Requirement
14
+ name: rake
15
+ requirement: !ruby/object:Gem::Requirement
16
16
requirements:
17
- - - ! '>='
17
+ - - ">="
18
18
- !ruby/object:Gem::Version
19
19
version: '0'
20
- none: false
20
+ type: :development
21
21
prerelease: false
22
- name: rake
22
+ version_requirements: !ruby/object:Gem::Requirement
23
+ requirements:
24
+ - - ">="
25
+ - !ruby/object:Gem::Version
26
+ version: '0'
27
+ - !ruby/object:Gem::Dependency
28
+ name: test-unit
23
29
requirement: !ruby/object:Gem::Requirement
24
30
requirements:
25
- - - ! '>='
31
+ - - ">="
26
32
- !ruby/object:Gem::Version
27
33
version: '0'
28
- none: false
29
34
type: :development
35
+ prerelease: false
36
+ version_requirements: !ruby/object:Gem::Requirement
37
+ requirements:
38
+ - - ">="
39
+ - !ruby/object:Gem::Version
40
+ version: '0'
30
41
description:
31
42
email:
32
43
- pawel.pacana@gmail.com
@@ -34,46 +45,39 @@ executables: []
34
45
extensions: []
35
46
extra_rdoc_files: []
36
47
files:
37
- - .gitignore
38
- - .travis.yml
48
+ - ".gitignore"
49
+ - ".travis.yml"
39
50
- CHANGELOG.md
40
51
- Gemfile
41
52
- LICENSE
42
53
- README.md
43
54
- Rakefile
44
55
- exponential-backoff.gemspec
56
+ - lib/exponential/backoff.rb
45
57
- lib/exponential_backoff.rb
46
58
- lib/exponential_backoff/version.rb
47
59
- test/exponential_backoff_test.rb
48
60
homepage: ''
49
61
licenses: []
62
+ metadata: {}
50
63
post_install_message:
51
64
rdoc_options: []
52
65
require_paths:
53
66
- lib
54
67
required_ruby_version: !ruby/object:Gem::Requirement
55
68
requirements:
56
- - - ! '>='
69
+ - - ">="
57
70
- !ruby/object:Gem::Version
58
71
version: '0'
59
- segments:
60
- - 0
61
- hash: 4010949273159976482
62
- none: false
63
72
required_rubygems_version: !ruby/object:Gem::Requirement
64
73
requirements:
65
- - - ! '>='
74
+ - - ">="
66
75
- !ruby/object:Gem::Version
67
76
version: '0'
68
- segments:
69
- - 0
70
- hash: 4010949273159976482
71
- none: false
72
77
requirements: []
73
- rubyforge_project:
78
+ rubygems_version: 3.0.4
74
- rubygems_version: 1.8.24
75
79
signing_key:
76
- specification_version: 3
80
+ specification_version: 4
77
81
summary: Exponential backoff algorithm for better reconnect intervals.
78
82
test_files:
79
83
- test/exponential_backoff_test.rb