checksums.yaml ADDED
@@ -0,0 +1,7 @@
1
+ ---
2
+ SHA256:
3
+ metadata.gz: 16e2d50fd1711c97719e64495e342530a9452b93adae1c5839b5dc63b5d0d10a
4
+ data.tar.gz: 9f7d5cdd2dc0947458d9cb1aea5fc13192d971cc73e148d18256d1a278c91c8d
5
+ SHA512:
6
+ metadata.gz: 763fa51ab38bb4980762ddaf2acb82fb09c6671888e160b877f2a7e01f8dde7055c705af0160d7759991bcad48e5ac94dd570b850daa66bf5eb4d07beed0806c
7
+ data.tar.gz: 5faf3811d054334db971bbd8c4620eb04939b83e7ea00b678c339589ae2e951397aa7402e993cced792bebf6dcbfafc44181f4a3d7a25f763b1d94cd7f2efda0
data/.github/PULL_REQUEST_TEMPLATE.md ADDED
@@ -0,0 +1,8 @@
1
+ # What
2
+ Technically describe what you did, add a screenshot if needed.
3
+ # Why
4
+ What is the business or user need behind what you did. User can be yourself!
5
+
6
+ ### Checklist
7
+ - [ ] Rebased on master
8
+ - [ ] Squashed commits to have tidy commit history
data/.github/main.workflow ADDED
@@ -0,0 +1,23 @@
1
+ workflow "Build, Test, and Publish" {
2
+ on = "push"
3
+ resolves = ["Publish"]
4
+ }
5
+
6
+ action "Build" {
7
+ uses = "scarhand/actions-ruby@master"
8
+ args = "build *.gemspec"
9
+ }
10
+
11
+ # Filter for a new tag
12
+ action "Tag" {
13
+ needs = "Build"
14
+ uses = "actions/bin/filter@master"
15
+ args = "tag v*"
16
+ }
17
+
18
+ action "Publish" {
19
+ needs = "Tag"
20
+ uses = "scarhand/actions-ruby@master"
21
+ args = "push *.gem"
22
+ secrets = ["RUBYGEMS_AUTH_TOKEN"]
23
+ }
data/.gitignore ADDED
@@ -0,0 +1,12 @@
1
+ /.bundle/
2
+ /.yardoc
3
+ /_yardoc/
4
+ /coverage/
5
+ /doc/
6
+ /pkg/
7
+ /spec/reports/
8
+ /tmp/
9
+
10
+ # rspec failure tracking
11
+ .rspec_status
12
+ *.gem
data/.jenkins/stack.yml ADDED
@@ -0,0 +1,12 @@
1
+ apiVersion: v1
2
+ kind: Pod
3
+ metadata:
4
+ labels:
5
+ name: bearer-ruby
6
+ spec:
7
+ containers:
8
+ - name: ruby261
9
+ image: ruby:2.6.1-alpine
10
+ command:
11
+ - cat
12
+ tty: true
data/.overcommit.yml ADDED
@@ -0,0 +1,38 @@
1
+ # Use this file to configure the Overcommit hooks you wish to use. This will
2
+ # extend the default configuration defined in:
3
+ # https://github.com/brigade/overcommit/blob/master/config/default.yml
4
+ #
5
+ # At the topmost level of this YAML file is a key representing type of hook
6
+ # being run (e.g. pre-commit, commit-msg, etc.). Within each type you can
7
+ # customize each hook, such as whether to only run it on certain files (via
8
+ # `include`), whether to only display output if it fails (via `quiet`), etc.
9
+ #
10
+ # For a complete list of hooks, see:
11
+ # https://github.com/brigade/overcommit/tree/master/lib/overcommit/hook
12
+ #
13
+ # For a complete list of options that you can use to customize hooks, see:
14
+ # https://github.com/brigade/overcommit#configuration
15
+ #
16
+ # Uncomment the following lines to make the configuration take effect.
17
+
18
+ PreCommit:
19
+ RuboCop:
20
+ enabled: true
21
+ command: ['bundle', 'exec', 'rubocop']
22
+ on_warn: fail # Treat all warnings as failures
23
+
24
+ include:
25
+ - '**/*.gemspec'
26
+ - '**/*.rb'
27
+ - '**/Gemfile'
28
+ - template-dir/hooks/overcommit-hook
29
+
30
+ TrailingWhitespace:
31
+ enabled: true
32
+
33
+ YamlSyntax:
34
+ enabled: true
35
+
36
+ CommitMsg:
37
+ CapitalizedSubject:
38
+ enabled: false
data/.rspec ADDED
@@ -0,0 +1,3 @@
1
+ --format documentation
2
+ --color
3
+ --require spec_helper
data/.rubocop.yml ADDED
@@ -0,0 +1,40 @@
1
+ AllCops:
2
+ TargetRubyVersion: 2.5
3
+ Exclude:
4
+ - '**/vendor/**/*'
5
+ - '**/vendor/**/.*'
6
+ - 'spec/**/*'
7
+ - 'bearer.gemspec'
8
+ - '.jenkins/**/*'
9
+ - 'bin/test'
10
+ - 'bin/console'
11
+ - 'bin/setup'
12
+
13
+ Style/StringLiterals:
14
+ Enabled: true
15
+ EnforcedStyle: double_quotes
16
+
17
+ Metrics/LineLength:
18
+ Exclude:
19
+ - 'config/**/*'
20
+ - 'spec/**/*'
21
+ Max: 120
22
+
23
+ Metrics/BlockLength:
24
+ Exclude:
25
+ - 'app/admin/**/*'
26
+
27
+ Metrics/MethodLength:
28
+ Max: 20
29
+
30
+ Style/Documentation:
31
+ Enabled: false
32
+
33
+ Layout/AlignHash:
34
+ Enabled: false
35
+
36
+ Layout/AlignParameters:
37
+ Enabled: false
38
+
39
+ Bundler/OrderedGems:
40
+ Enabled: false
data/.ruby-version ADDED
@@ -0,0 +1 @@
1
+ 2.6.1
data/.travis.yml ADDED
@@ -0,0 +1,5 @@
1
+ sudo: false
2
+ language: ruby
3
+ rvm:
4
+ - 2.4.3
5
+ before_install: gem install bundler -v 1.16.1
data/CODE_OF_CONDUCT.md ADDED
@@ -0,0 +1,74 @@
1
+ # Contributor Covenant Code of Conduct
2
+
3
+ ## Our Pledge
4
+
5
+ In the interest of fostering an open and welcoming environment, we as
6
+ contributors and maintainers pledge to making participation in our project and
7
+ our community a harassment-free experience for everyone, regardless of age, body
8
+ size, disability, ethnicity, gender identity and expression, level of experience,
9
+ nationality, personal appearance, race, religion, or sexual identity and
10
+ orientation.
11
+
12
+ ## Our Standards
13
+
14
+ Examples of behavior that contributes to creating a positive environment
15
+ include:
16
+
17
+ * Using welcoming and inclusive language
18
+ * Being respectful of differing viewpoints and experiences
19
+ * Gracefully accepting constructive criticism
20
+ * Focusing on what is best for the community
21
+ * Showing empathy towards other community members
22
+
23
+ Examples of unacceptable behavior by participants include:
24
+
25
+ * The use of sexualized language or imagery and unwelcome sexual attention or
26
+ advances
27
+ * Trolling, insulting/derogatory comments, and personal or political attacks
28
+ * Public or private harassment
29
+ * Publishing others' private information, such as a physical or electronic
30
+ address, without explicit permission
31
+ * Other conduct which could reasonably be considered inappropriate in a
32
+ professional setting
33
+
34
+ ## Our Responsibilities
35
+
36
+ Project maintainers are responsible for clarifying the standards of acceptable
37
+ behavior and are expected to take appropriate and fair corrective action in
38
+ response to any instances of unacceptable behavior.
39
+
40
+ Project maintainers have the right and responsibility to remove, edit, or
41
+ reject comments, commits, code, wiki edits, issues, and other contributions
42
+ that are not aligned to this Code of Conduct, or to ban temporarily or
43
+ permanently any contributor for other behaviors that they deem inappropriate,
44
+ threatening, offensive, or harmful.
45
+
46
+ ## Scope
47
+
48
+ This Code of Conduct applies both within project spaces and in public spaces
49
+ when an individual is representing the project or its community. Examples of
50
+ representing a project or community include using an official project e-mail
51
+ address, posting via an official social media account, or acting as an appointed
52
+ representative at an online or offline event. Representation of a project may be
53
+ further defined and clarified by project maintainers.
54
+
55
+ ## Enforcement
56
+
57
+ Instances of abusive, harassing, or otherwise unacceptable behavior may be
58
+ reported by contacting the project team at antoine@bearer.sh. All
59
+ complaints will be reviewed and investigated and will result in a response that
60
+ is deemed necessary and appropriate to the circumstances. The project team is
61
+ obligated to maintain confidentiality with regard to the reporter of an incident.
62
+ Further details of specific enforcement policies may be posted separately.
63
+
64
+ Project maintainers who do not follow or enforce the Code of Conduct in good
65
+ faith may face temporary or permanent repercussions as determined by other
66
+ members of the project's leadership.
67
+
68
+ ## Attribution
69
+
70
+ This Code of Conduct is adapted from the [Contributor Covenant][homepage], version 1.4,
71
+ available at [http://contributor-covenant.org/version/1/4][version]
72
+
73
+ [homepage]: http://contributor-covenant.org
74
+ [version]: http://contributor-covenant.org/version/1/4/
data/Gemfile ADDED
@@ -0,0 +1,9 @@
1
+ # frozen_string_literal: true
2
+
3
+ source "https://rubygems.org"
4
+
5
+ git_source(:github) { |repo_name| "https://github.com/#{repo_name}" }
6
+
7
+ gem "webmock"
8
+ # Specify your gem's dependencies in bearer.gemspec
9
+ gemspec
data/Gemfile.lock ADDED
@@ -0,0 +1,81 @@
1
+ PATH
2
+ remote: .
3
+ specs:
4
+ bearer (0.1.0)
5
+
6
+ GEM
7
+ remote: https://rubygems.org/
8
+ specs:
9
+ addressable (2.6.0)
10
+ public_suffix (>= 2.0.2, < 4.0)
11
+ ast (2.4.0)
12
+ childprocess (0.9.0)
13
+ ffi (~> 1.0, >= 1.0.11)
14
+ coderay (1.1.2)
15
+ crack (0.4.3)
16
+ safe_yaml (~> 1.0.0)
17
+ diff-lcs (1.3)
18
+ ffi (1.10.0)
19
+ hashdiff (0.3.8)
20
+ iniparse (1.4.4)
21
+ jaro_winkler (1.5.2)
22
+ method_source (0.9.2)
23
+ overcommit (0.46.0)
24
+ childprocess (~> 0.6, >= 0.6.3)
25
+ iniparse (~> 1.4)
26
+ parallel (1.14.0)
27
+ parser (2.6.0.0)
28
+ ast (~> 2.4.0)
29
+ powerpack (0.1.2)
30
+ pry (0.12.2)
31
+ coderay (~> 1.1.0)
32
+ method_source (~> 0.9.0)
33
+ psych (3.1.0)
34
+ public_suffix (3.0.3)
35
+ rainbow (3.0.0)
36
+ rake (10.5.0)
37
+ rspec (3.8.0)
38
+ rspec-core (~> 3.8.0)
39
+ rspec-expectations (~> 3.8.0)
40
+ rspec-mocks (~> 3.8.0)
41
+ rspec-core (3.8.0)
42
+ rspec-support (~> 3.8.0)
43
+ rspec-expectations (3.8.2)
44
+ diff-lcs (>= 1.2.0, < 2.0)
45
+ rspec-support (~> 3.8.0)
46
+ rspec-mocks (3.8.0)
47
+ diff-lcs (>= 1.2.0, < 2.0)
48
+ rspec-support (~> 3.8.0)
49
+ rspec-support (3.8.0)
50
+ rubocop (0.65.0)
51
+ jaro_winkler (~> 1.5.1)
52
+ parallel (~> 1.10)
53
+ parser (>= 2.5, != 2.5.1.1)
54
+ powerpack (~> 0.1)
55
+ psych (>= 3.1.0)
56
+ rainbow (>= 2.2.2, < 4.0)
57
+ ruby-progressbar (~> 1.7)
58
+ unicode-display_width (~> 1.4.0)
59
+ ruby-progressbar (1.10.0)
60
+ safe_yaml (1.0.5)
61
+ unicode-display_width (1.4.1)
62
+ webmock (3.5.1)
63
+ addressable (>= 2.3.6)
64
+ crack (>= 0.3.2)
65
+ hashdiff
66
+
67
+ PLATFORMS
68
+ ruby
69
+
70
+ DEPENDENCIES
71
+ bearer!
72
+ bundler (~> 1.16)
73
+ overcommit
74
+ pry
75
+ rake (~> 10.0)
76
+ rspec (~> 3.0)
77
+ rubocop (~> 0.65.0)
78
+ webmock
79
+
80
+ BUNDLED WITH
81
+ 1.17.2
data/Jenkinsfile ADDED
@@ -0,0 +1,39 @@
1
+ def label() {
2
+ def value = "bearer-ruby-${UUID.randomUUID().toString()}"
3
+ return value
4
+ }
5
+
6
+
7
+ pipeline {
8
+ agent {
9
+ kubernetes {
10
+ label label()
11
+ defaultContainer 'jnlp'
12
+ yamlFile '.jenkins/stack.yml'
13
+ }
14
+ } // and agent
15
+
16
+ stages {
17
+ stage("Rubocop") {
18
+ steps {
19
+ container("ruby261") {
20
+ ansiColor('xterm') {
21
+ sh "apk add --update git make build-base"
22
+ sh "bundle --jobs 20 --retry 5 --path=vendor"
23
+ sh "bundle exec rubocop -c .rubocop.yml"
24
+ }
25
+ }
26
+ }
27
+ }//end stage
28
+
29
+ stage("Tests") {
30
+ steps {
31
+ container("ruby261") {
32
+ ansiColor('xterm') {
33
+ sh "bin/test"
34
+ }
35
+ }
36
+ }
37
+ }//end stage
38
+ }// end stages
39
+ } // end pipeline
data/README.md ADDED
@@ -0,0 +1,39 @@
1
+ # Bearer
2
+
3
+ Welcome to your new gem! In this directory, you'll find the files you need to be able to package up your Ruby library into a gem. Put your Ruby code in the file `lib/bearer`. To experiment with that code, run `bin/console` for an interactive prompt.
4
+
5
+ TODO: Delete this and the text above, and describe your gem
6
+
7
+ ## Installation
8
+
9
+ Add this line to your application's Gemfile:
10
+
11
+ ```ruby
12
+ gem 'bearer'
13
+ ```
14
+
15
+ And then execute:
16
+
17
+ $ bundle
18
+
19
+ Or install it yourself as:
20
+
21
+ $ gem install bearer
22
+
23
+ ## Usage
24
+
25
+ TODO: Write usage instructions here
26
+
27
+ ## Development
28
+
29
+ After checking out the repo, run `bin/setup` to install dependencies. Then, run `rake spec` to run the tests. You can also run `bin/console` for an interactive prompt that will allow you to experiment.
30
+
31
+ To install this gem onto your local machine, run `bundle exec rake install`. To release a new version, update the version number in `version.rb`, and then run `bundle exec rake release`, which will create a git tag for the version, push git commits and tags, and push the `.gem` file to [rubygems.org](https://rubygems.org).
32
+
33
+ ## Contributing
34
+
35
+ Bug reports and pull requests are welcome on GitHub at https://github.com/[USERNAME]/bearer. This project is intended to be a safe, welcoming space for collaboration, and contributors are expected to adhere to the [Contributor Covenant](http://contributor-covenant.org) code of conduct.
36
+
37
+ ## Code of Conduct
38
+
39
+ Everyone interacting in the Bearer project’s codebases, issue trackers, chat rooms and mailing lists is expected to follow the [code of conduct](https://github.com/[USERNAME]/bearer/blob/master/CODE_OF_CONDUCT.md).
data/Rakefile ADDED
@@ -0,0 +1,8 @@
1
+ # frozen_string_literal: true
2
+
3
+ require "bundler/gem_tasks"
4
+ require "rspec/core/rake_task"
5
+
6
+ RSpec::Core::RakeTask.new(:spec)
7
+
8
+ task default: :spec
data/bearer.gemspec ADDED
@@ -0,0 +1,35 @@
1
+ lib = File.expand_path("../lib", __FILE__)
2
+ $LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
3
+ require "bearer/version"
4
+
5
+ Gem::Specification.new do |spec|
6
+ spec.name = "bearer"
7
+ spec.version = Bearer::VERSION
8
+ spec.authors = ["Bearer Team<engineering@bearer.sh>"]
9
+ spec.email = ["antoine@bearer.sh"]
10
+
11
+ spec.summary = %q{Bearer Ruby}
12
+ spec.description = %q{Bearer Ruby description}
13
+ spec.homepage = "https://www.bearer.sh"
14
+ spec.licenses = ['MIT']
15
+ if spec.respond_to?(:metadata)
16
+ spec.metadata["allowed_push_host"] = "https://rubygems.org/"
17
+ else
18
+ raise "RubyGems 2.0 or newer is required to protect against " \
19
+ "public gem pushes."
20
+ end
21
+
22
+ spec.files = `git ls-files -z`.split("\x0").reject do |f|
23
+ f.match(%r{^(test|spec|features)/})
24
+ end
25
+ spec.bindir = "exe"
26
+ spec.executables = spec.files.grep(%r{^exe/}) { |f| File.basename(f) }
27
+ spec.require_paths = ["lib"]
28
+
29
+ spec.add_development_dependency "bundler", "~> 1.16"
30
+ spec.add_development_dependency "rake", "~> 10.0"
31
+ spec.add_development_dependency "rspec", "~> 3.0"
32
+ spec.add_development_dependency "rubocop", "~> 0.65.0"
33
+ spec.add_development_dependency "pry"
34
+ spec.add_development_dependency "overcommit"
35
+ end
data/bin/console ADDED
@@ -0,0 +1,11 @@
1
+ #!/usr/bin/env ruby
2
+ # frozen_string_literal: true
3
+
4
+ require "bundler/setup"
5
+ require_relative "../lib/bearer"
6
+
7
+ # You can add fixtures and/or initialization code here to make experimenting
8
+ # with your gem easier. You can also use a different console, if you like.
9
+
10
+ require "pry"
11
+ Pry.start
data/bin/setup ADDED
@@ -0,0 +1,11 @@
1
+ #!/usr/bin/env bash
2
+
3
+ set -euo pipefail
4
+
5
+ IFS=#x27;\n\t'
6
+ set -vx
7
+
8
+ bundle install
9
+
10
+ # Do any other automated setup that you need to do here
11
+ overcommit --install
data/bin/test ADDED
@@ -0,0 +1,8 @@
1
+ #!/usr/bin/env sh
2
+
3
+ set -euo pipefail
4
+
5
+ IFS=#x27;\n\t'
6
+ set -vx
7
+
8
+ bundle exec rake spec
data/lib/bearer.rb ADDED
@@ -0,0 +1,27 @@
1
+ # frozen_string_literal: true
2
+
3
+ require_relative "./bearer/version"
4
+ require_relative "./bearer/configuration"
5
+ require "net/http"
6
+ require "json"
7
+
8
+ module Bearer
9
+ INT_URL = "https://int.bearer.sh/api/v3/functions/backend/"
10
+
11
+ def self.call(integration_uuid, integration_name, params: {}, body: {})
12
+ uri = URI("#{INT_URL}#{integration_uuid}/#{integration_name}")
13
+ uri.query = params.map { |k, v| "#{k}=#{v}" }.join("&")
14
+
15
+ req = Net::HTTP::Post.new(
16
+ uri,
17
+ "Content-Type" => "application/json",
18
+ "Authorization" => Bearer::Configuration.api_key,
19
+ "User-Agent" => "Bearer (#{Bearer::VERSION})"
20
+ )
21
+ req.body = body.to_json
22
+ res = Net::HTTP.start(uri.hostname, uri.port, use_ssl: uri.scheme == "https") do |http|
23
+ http.request(req)
24
+ end
25
+ JSON.parse(res.body)
26
+ end
27
+ end
data/lib/bearer/configuration.rb ADDED
@@ -0,0 +1,48 @@
1
+ # frozen_string_literal: true
2
+
3
+ require "singleton"
4
+
5
+ require_relative "./errors"
6
+
7
+ module Bearer
8
+ class Configuration
9
+ include Singleton
10
+
11
+ FIELDS = %i[api_key client_id secret].freeze
12
+
13
+ attr_writer(*FIELDS)
14
+
15
+ FIELDS.each do |field|
16
+ define_method field do
17
+ value = instance_variable_get(:"@#{field}")
18
+
19
+ raise ::Bearer::Errors::Configuration, "Bearer #{field} is missing!" unless value
20
+
21
+ value
22
+ end
23
+ end
24
+
25
+ class << self
26
+ EXISTING_METHODS = FIELDS.flat_map { |field| [field, "#{field}=".to_sym] }
27
+
28
+ def method_missing(name, *args, &block)
29
+ super unless EXISTING_METHODS.include? name
30
+ instance.public_send(name, *args, &block)
31
+ end
32
+
33
+ def respond_to_missing?(name, include_private = false)
34
+ EXISTING_METHODS.include?(name) || super
35
+ end
36
+ end
37
+
38
+ def self.reset
39
+ FIELDS.each do |field|
40
+ instance.public_send("#{field}=", nil)
41
+ end
42
+ end
43
+
44
+ def self.setup
45
+ yield(instance)
46
+ end
47
+ end
48
+ end
data/lib/bearer/errors.rb ADDED
@@ -0,0 +1,7 @@
1
+ # frozen_string_literal: true
2
+
3
+ module Bearer
4
+ module Errors
5
+ class Configuration < StandardError; end
6
+ end
7
+ end
data/lib/bearer/version.rb ADDED
@@ -0,0 +1,5 @@
1
+ # frozen_string_literal: true
2
+
3
+ module Bearer
4
+ VERSION = "0.1.1"
5
+ end
metadata ADDED
@@ -0,0 +1,151 @@
1
+ --- !ruby/object:Gem::Specification
2
+ name: bearer
3
+ version: !ruby/object:Gem::Version
4
+ version: 0.1.1
5
+ platform: ruby
6
+ authors:
7
+ - Bearer Team<engineering@bearer.sh>
8
+ autorequire:
9
+ bindir: exe
10
+ cert_chain: []
11
+ date: 2019-03-20 00:00:00.000000000 Z
12
+ dependencies:
13
+ - !ruby/object:Gem::Dependency
14
+ name: bundler
15
+ requirement: !ruby/object:Gem::Requirement
16
+ requirements:
17
+ - - "~>"
18
+ - !ruby/object:Gem::Version
19
+ version: '1.16'
20
+ type: :development
21
+ prerelease: false
22
+ version_requirements: !ruby/object:Gem::Requirement
23
+ requirements:
24
+ - - "~>"
25
+ - !ruby/object:Gem::Version
26
+ version: '1.16'
27
+ - !ruby/object:Gem::Dependency
28
+ name: rake
29
+ requirement: !ruby/object:Gem::Requirement
30
+ requirements:
31
+ - - "~>"
32
+ - !ruby/object:Gem::Version
33
+ version: '10.0'
34
+ type: :development
35
+ prerelease: false
36
+ version_requirements: !ruby/object:Gem::Requirement
37
+ requirements:
38
+ - - "~>"
39
+ - !ruby/object:Gem::Version
40
+ version: '10.0'
41
+ - !ruby/object:Gem::Dependency
42
+ name: rspec
43
+ requirement: !ruby/object:Gem::Requirement
44
+ requirements:
45
+ - - "~>"
46
+ - !ruby/object:Gem::Version
47
+ version: '3.0'
48
+ type: :development
49
+ prerelease: false
50
+ version_requirements: !ruby/object:Gem::Requirement
51
+ requirements:
52
+ - - "~>"
53
+ - !ruby/object:Gem::Version
54
+ version: '3.0'
55
+ - !ruby/object:Gem::Dependency
56
+ name: rubocop
57
+ requirement: !ruby/object:Gem::Requirement
58
+ requirements:
59
+ - - "~>"
60
+ - !ruby/object:Gem::Version
61
+ version: 0.65.0
62
+ type: :development
63
+ prerelease: false
64
+ version_requirements: !ruby/object:Gem::Requirement
65
+ requirements:
66
+ - - "~>"
67
+ - !ruby/object:Gem::Version
68
+ version: 0.65.0
69
+ - !ruby/object:Gem::Dependency
70
+ name: pry
71
+ requirement: !ruby/object:Gem::Requirement
72
+ requirements:
73
+ - - ">="
74
+ - !ruby/object:Gem::Version
75
+ version: '0'
76
+ type: :development
77
+ prerelease: false
78
+ version_requirements: !ruby/object:Gem::Requirement
79
+ requirements:
80
+ - - ">="
81
+ - !ruby/object:Gem::Version
82
+ version: '0'
83
+ - !ruby/object:Gem::Dependency
84
+ name: overcommit
85
+ requirement: !ruby/object:Gem::Requirement
86
+ requirements:
87
+ - - ">="
88
+ - !ruby/object:Gem::Version
89
+ version: '0'
90
+ type: :development
91
+ prerelease: false
92
+ version_requirements: !ruby/object:Gem::Requirement
93
+ requirements:
94
+ - - ">="
95
+ - !ruby/object:Gem::Version
96
+ version: '0'
97
+ description: Bearer Ruby description
98
+ email:
99
+ - antoine@bearer.sh
100
+ executables: []
101
+ extensions: []
102
+ extra_rdoc_files: []
103
+ files:
104
+ - ".github/PULL_REQUEST_TEMPLATE.md"
105
+ - ".github/main.workflow"
106
+ - ".gitignore"
107
+ - ".jenkins/stack.yml"
108
+ - ".overcommit.yml"
109
+ - ".rspec"
110
+ - ".rubocop.yml"
111
+ - ".ruby-version"
112
+ - ".travis.yml"
113
+ - CODE_OF_CONDUCT.md
114
+ - Gemfile
115
+ - Gemfile.lock
116
+ - Jenkinsfile
117
+ - README.md
118
+ - Rakefile
119
+ - bearer.gemspec
120
+ - bin/console
121
+ - bin/setup
122
+ - bin/test
123
+ - lib/bearer.rb
124
+ - lib/bearer/configuration.rb
125
+ - lib/bearer/errors.rb
126
+ - lib/bearer/version.rb
127
+ homepage: https://www.bearer.sh
128
+ licenses:
129
+ - MIT
130
+ metadata:
131
+ allowed_push_host: https://rubygems.org/
132
+ post_install_message:
133
+ rdoc_options: []
134
+ require_paths:
135
+ - lib
136
+ required_ruby_version: !ruby/object:Gem::Requirement
137
+ requirements:
138
+ - - ">="
139
+ - !ruby/object:Gem::Version
140
+ version: '0'
141
+ required_rubygems_version: !ruby/object:Gem::Requirement
142
+ requirements:
143
+ - - ">="
144
+ - !ruby/object:Gem::Version
145
+ version: '0'
146
+ requirements: []
147
+ rubygems_version: 3.0.3
148
+ signing_key:
149
+ specification_version: 4
150
+ summary: Bearer Ruby
151
+ test_files: []