checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 8d783a45eb2febfafd768163491bd7b53984b25168b02b773f4e0f37968049c3
4
- data.tar.gz: a0a5930c4b81481fc35032634eb99f5fea60821e931ecdfed9df7a89e9a14628
3
+ metadata.gz: d076c64f427cee75b8f8a48b388356e671686c281ceb0c1adc49eaeedf02b0a2
4
+ data.tar.gz: 31642ca675e64102b5749e9fc2d4db98c53af10e8eb79eb5f9d21c2d5ffe5425
5
5
SHA512:
6
- metadata.gz: 3d2f4af6a04e715bb9c4c84db680238a0d4002841a4514a7d5a8c5b8af62c87e84a3f40c0d76e976f045fb8de8475bf059cfca9d507c7a86e0fb19f56e05102a
7
- data.tar.gz: f05c2a525c0b883e43c019e2881b3710ee9a1fb82224db128d977da209fa8a6cfdb69670a4a5d8828ca5bd4fa22afda0dab994719bbc80f5d9a108821858995e
6
+ metadata.gz: 06c18f13f66d7e0f3bfbac9d0e3b8d4506ca6221a76f5d9907468c02c2fdad6fec1c15357cb42f738d440bc6ced0fb4a1b3832ed2fcc80b4d9057215b045ade8
7
+ data.tar.gz: 2cfd9ca70d5b6203b62cd18c62cd2ac2d11fa3364488bef678eb35532bc2ca9b2fee76b13602d5d415df77c5c1ea53766f3eb4ee4012466d56bc323f82b0e675
data/CHANGELOG.md CHANGED
@@ -1,3 +1,8 @@
1
+ ## Rails 6.0.0 (August 16, 2019) ##
2
+
3
+ * No changes.
4
+
5
+
1
6
## Rails 6.0.0.rc2 (July 22, 2019) ##
2
7
3
8
* No changes.
data/app/helpers/action_text/content_helper.rb CHANGED
@@ -4,7 +4,7 @@ require "rails-html-sanitizer"
4
4
5
5
module ActionText
6
6
module ContentHelper
7
- mattr_accessor(:sanitizer) { Rails::Html::Sanitizer.white_list_sanitizer.new }
7
+ mattr_accessor(:sanitizer) { Rails::Html::Sanitizer.safe_list_sanitizer.new }
8
8
mattr_accessor(:allowed_tags) { sanitizer.class.allowed_tags + [ ActionText::Attachment::TAG_NAME, "figure", "figcaption" ] }
9
9
mattr_accessor(:allowed_attributes) { sanitizer.class.allowed_attributes + ActionText::Attachment::ATTRIBUTES }
10
10
mattr_accessor(:scrubber)
data/lib/action_text/gem_version.rb CHANGED
@@ -10,7 +10,7 @@ module ActionText
10
10
MAJOR = 6
11
11
MINOR = 0
12
12
TINY = 0
13
- PRE = "rc2"
13
+ PRE = nil
14
14
15
15
STRING = [MAJOR, MINOR, TINY, PRE].compact.join(".")
16
16
end
data/package.json CHANGED
@@ -1,6 +1,6 @@
1
1
{
2
2
"name": "@rails/actiontext",
3
- "version": "6.0.0-rc2",
3
+ "version": "6.0.0",
4
4
"description": "Edit and display rich text in Rails applications",
5
5
"main": "app/javascript/actiontext/index.js",
6
6
"files": [
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: actiontext
3
3
version: !ruby/object:Gem::Version
4
- version: 6.0.0.rc2
4
+ version: 6.0.0
5
5
platform: ruby
6
6
authors:
7
7
- Javan Makhmali
@@ -10,7 +10,7 @@ authors:
10
10
autorequire:
11
11
bindir: bin
12
12
cert_chain: []
13
- date: 2019-07-22 00:00:00.000000000 Z
13
+ date: 2019-08-16 00:00:00.000000000 Z
14
14
dependencies:
15
15
- !ruby/object:Gem::Dependency
16
16
name: activesupport
@@ -18,56 +18,56 @@ dependencies:
18
18
requirements:
19
19
- - '='
20
20
- !ruby/object:Gem::Version
21
- version: 6.0.0.rc2
21
+ version: 6.0.0
22
22
type: :runtime
23
23
prerelease: false
24
24
version_requirements: !ruby/object:Gem::Requirement
25
25
requirements:
26
26
- - '='
27
27
- !ruby/object:Gem::Version
28
- version: 6.0.0.rc2
28
+ version: 6.0.0
29
29
- !ruby/object:Gem::Dependency
30
30
name: activerecord
31
31
requirement: !ruby/object:Gem::Requirement
32
32
requirements:
33
33
- - '='
34
34
- !ruby/object:Gem::Version
35
- version: 6.0.0.rc2
35
+ version: 6.0.0
36
36
type: :runtime
37
37
prerelease: false
38
38
version_requirements: !ruby/object:Gem::Requirement
39
39
requirements:
40
40
- - '='
41
41
- !ruby/object:Gem::Version
42
- version: 6.0.0.rc2
42
+ version: 6.0.0
43
43
- !ruby/object:Gem::Dependency
44
44
name: activestorage
45
45
requirement: !ruby/object:Gem::Requirement
46
46
requirements:
47
47
- - '='
48
48
- !ruby/object:Gem::Version
49
- version: 6.0.0.rc2
49
+ version: 6.0.0
50
50
type: :runtime
51
51
prerelease: false
52
52
version_requirements: !ruby/object:Gem::Requirement
53
53
requirements:
54
54
- - '='
55
55
- !ruby/object:Gem::Version
56
- version: 6.0.0.rc2
56
+ version: 6.0.0
57
57
- !ruby/object:Gem::Dependency
58
58
name: actionpack
59
59
requirement: !ruby/object:Gem::Requirement
60
60
requirements:
61
61
- - '='
62
62
- !ruby/object:Gem::Version
63
- version: 6.0.0.rc2
63
+ version: 6.0.0
64
64
type: :runtime
65
65
prerelease: false
66
66
version_requirements: !ruby/object:Gem::Requirement
67
67
requirements:
68
68
- - '='
69
69
- !ruby/object:Gem::Version
70
- version: 6.0.0.rc2
70
+ version: 6.0.0
71
71
- !ruby/object:Gem::Dependency
72
72
name: nokogiri
73
73
requirement: !ruby/object:Gem::Requirement
@@ -134,8 +134,8 @@ homepage: https://rubyonrails.org
134
134
licenses:
135
135
- MIT
136
136
metadata:
137
- source_code_uri: https://github.com/rails/rails/tree/v6.0.0.rc2/actiontext
138
- changelog_uri: https://github.com/rails/rails/blob/v6.0.0.rc2/actiontext/CHANGELOG.md
137
+ source_code_uri: https://github.com/rails/rails/tree/v6.0.0/actiontext
138
+ changelog_uri: https://github.com/rails/rails/blob/v6.0.0/actiontext/CHANGELOG.md
139
139
post_install_message:
140
140
rdoc_options: []
141
141
require_paths:
@@ -147,9 +147,9 @@ required_ruby_version: !ruby/object:Gem::Requirement
147
147
version: 2.5.0
148
148
required_rubygems_version: !ruby/object:Gem::Requirement
149
149
requirements:
150
- - - ">"
150
+ - - ">="
151
151
- !ruby/object:Gem::Version
152
- version: 1.3.1
152
+ version: '0'
153
153
requirements: []
154
154
rubygems_version: 3.0.1
155
155
signing_key: