checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 31f22a9a97254698d652e6724a019c23db31f7a3550c31cd8b69dc1697103cd8
4
- data.tar.gz: a4bc81e134d549c8cb8001403281fa4b4c535b44e1598a77d2a7c10b74851c6f
3
+ metadata.gz: b3b37255b188591ca005e9421faf46d08a6906e5d13d7b6d2bc27cc278dde8ea
4
+ data.tar.gz: 1d3faec5a30ce6c2cbe41b7c543b9e1b3fd9162320c2a8babf08533b4aebec41
5
5
SHA512:
6
- metadata.gz: 6abbeff6a818cbe8ceff2f5737c564c336baded7d58df41508a0ae0e28b32021e1bfadd0fef206c6c6df30acc709002a343ebe1d1e2afdf70d3708f6caef9fb4
7
- data.tar.gz: 6ac071032f401ac1aae354a4de86189e665918be1060104fa3a83a8dfeb645fb345a70b24b7455c4bce1074315232e70425df9e837c01d54f9e187bb401c1a67
6
+ metadata.gz: f2dce0a879ba0931ed9ff2544ebabae420780a3f6c25bc9617f36c833758d4408f4c2ef388ed5bf59974a225d6cdfa2a578d217f5c552f9b0abfc0242de381c1
7
+ data.tar.gz: b29d086dcf4a9c93f5892ae204ac1f0ad8a51cd24d918fdcecc56f02cc87de8b99cdeccce4eb2111de563d923aa4059ed8f294a2f1c00c71f066d3cb313de15b
data/CHANGELOG.md CHANGED
@@ -17,6 +17,13 @@ This project adheres to [Semantic Versioning](http://semver.org/) and [Keep a Ch
17
17
### Breaks
18
18
19
19
20
+ ## 2.0.1 - (2019-08-09)
21
+ ---
22
+
23
+ ### Fixes
24
+ * Fix check if assets option node already exists
25
+
26
+
20
27
## 2.0.0 - (2019-08-08)
21
28
---
22
29
data/lib/rails/assets/manifest/railtie.rb CHANGED
@@ -8,7 +8,9 @@ module Rails
8
8
# already exists and must not be overriden. Otherwise
9
9
# all sprockets default options are removed breaking
10
10
# sprockets.
11
- config.assets ||= ::ActiveSupport::OrderedOptions.new
11
+ unless config.respond_to?(:assets)
12
+ config.assets = ::ActiveSupport::OrderedOptions.new
13
+ end
12
14
13
15
# Path where the manifest files are loaded from.
14
16
config.assets.manifests = ['public/assets/manifest.json']
data/lib/rails/assets/manifest/version.rb CHANGED
@@ -6,7 +6,7 @@ module Rails
6
6
module VERSION
7
7
MAJOR = 2
8
8
MINOR = 0
9
- PATCH = 0
9
+ PATCH = 1
10
10
STAGE = nil
11
11
12
12
STRING = [MAJOR, MINOR, PATCH, STAGE].reject(&:nil?).join('.')
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: rails-assets-manifest
3
3
version: !ruby/object:Gem::Version
4
- version: 2.0.0
4
+ version: 2.0.1
5
5
platform: ruby
6
6
authors:
7
7
- Jan Graichen
8
8
autorequire:
9
9
bindir: exe
10
10
cert_chain: []
11
- date: 2019-08-08 00:00:00.000000000 Z
11
+ date: 2019-08-09 00:00:00.000000000 Z
12
12
dependencies:
13
13
- !ruby/object:Gem::Dependency
14
14
name: activesupport