checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 48f0c775bc9c06fa4941bd20b903cf38dca11a86ac7c258f809773e701e9805d
4
- data.tar.gz: 4fdc93ba99325be6512429b40b2accdce93096091734119df9baa418455763c1
3
+ metadata.gz: a1ce2e992ce1a5fd8274e579b0ba721e3a2d2e0a2c832e3d4e64e22118818aca
4
+ data.tar.gz: fe4439d634d44737883aca3e08d16537cffced5445a71b18462dba9356f3f827
5
5
SHA512:
6
- metadata.gz: 721f12023eea66b9eb26f86926d667b614b9b696865cdef97b05916b01f6635f0a830909b0653d7b78b37dcbbf56c4e26142d8b93685e98e805891b15c7f1263
7
- data.tar.gz: 443d5b04f1849d595aec927d934c9638c4a7cd169305e368b0c451322680b89c95005dc093850976418ea6eeadc9daacbbdcf67a7dce9cec21c59c54ee3f1aa3
6
+ metadata.gz: 052bda57f4c9c1e2d63e576c4714dfb2d243efb645c7b1271b823525b0114323f593f88bfe8c967ec5b1fed77e9534d60395f379620a9a946a84851c2c2ce49b
7
+ data.tar.gz: 2ec5e631e6492390fb5b3f19d33873f50dbc1ab2c6804646082d48d89653b293aa12e12b60d0102439f765937101144cc3692316a24f59aae4f2299631af9101
data/app/controllers/tramway/api/v1/records_controller.rb CHANGED
@@ -8,6 +8,7 @@ module Tramway::Api::V1
8
8
records = model_class.active.order(id: :desc).send params[:scope] || :all
9
9
render json: records,
10
10
each_serializer: serializer_class,
11
+ include: '*',
11
12
status: :ok
12
13
end
13
14
@@ -16,6 +17,7 @@ module Tramway::Api::V1
16
17
if record_form.submit params[:data][:attributes]
17
18
render json: record_form.model,
18
19
serializer: serializer_class,
20
+ include: '*',
19
21
status: :created
20
22
else
21
23
render_errors_for record_form
@@ -27,6 +29,7 @@ module Tramway::Api::V1
27
29
if record_form.submit params[:data][:attributes]
28
30
render json: record_form.model,
29
31
serializer: serializer_class,
32
+ include: '*',
30
33
status: :ok
31
34
else
32
35
render_errors_for record_form
@@ -46,6 +49,7 @@ module Tramway::Api::V1
46
49
record.remove
47
50
render json: record,
48
51
serializer: serializer_class,
52
+ include: '*',
49
53
status: :no_content
50
54
end
51
55
data/lib/tramway/api/version.rb CHANGED
@@ -1,5 +1,5 @@
1
1
module Tramway
2
2
module Api
3
- VERSION = '1.4.2'
3
+ VERSION = '1.4.3'
4
4
end
5
5
end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: tramway-api
3
3
version: !ruby/object:Gem::Version
4
- version: 1.4.2
4
+ version: 1.4.3
5
5
platform: ruby
6
6
authors:
7
7
- Pavel Kalashnikov