checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA1:
3
- metadata.gz: 144159e28d5ab2e7b772fbf4d94c4e3e0c30911d
4
- data.tar.gz: ed771a0f5289b38921fcf2ff693f4c02a2a16d78
3
+ metadata.gz: f5d3ba8e111d5249dca4e3c3e9610f9cdeade77e
4
+ data.tar.gz: 034d14c88812d2ff709d8d961e6c2a2a298f3768
5
5
SHA512:
6
- metadata.gz: c63e21252f3b25b7702dd680275f7b31766b7422fbd70e205f99d0470bce7b8f13e328a24811a54d5d0afa9ecb3d0f2eaf2e591d88ae5b3b21207fb61d122a2c
7
- data.tar.gz: 85f8ded16ebe89979724e977a80ed0f73b181d7c56dd643c0cd56c1972ab60f906a4a966026cfa16ab4792c091323a3234df550b4500ee08c14a889e239b1413
6
+ metadata.gz: 7e2a27c9d109eea4a1cac9f3bf00199a040fa3488ac94ba7d98bfaf0f9eff990c61828d42048efc32de061b03607a4a0e8aad83965e69dd191fdef29633a172e
7
+ data.tar.gz: 49501180befecc4418e4aba8605c6df91f9b17d095611e3c2172c5085f277f62d17c041b9c4ef82350aff9ede72942bb09164ca119e23a849e314df0fa623aed
data/lib/aws-sdk-appsync.rb CHANGED
@@ -42,6 +42,6 @@ require_relative 'aws-sdk-appsync/customizations'
42
42
# @service
43
43
module Aws::AppSync
44
44
45
- GEM_VERSION = '1.19.0'
45
+ GEM_VERSION = '1.20.0'
46
46
47
47
end
data/lib/aws-sdk-appsync/client.rb CHANGED
@@ -508,6 +508,7 @@ module Aws::AppSync
508
508
# log_config: {
509
509
# field_log_level: "NONE", # required, accepts NONE, ERROR, ALL
510
510
# cloud_watch_logs_role_arn: "String", # required
511
+ # exclude_verbose_content: false,
511
512
# },
512
513
# authentication_type: "API_KEY", # required, accepts API_KEY, AWS_IAM, AMAZON_COGNITO_USER_POOLS, OPENID_CONNECT
513
514
# user_pool_config: {
@@ -550,6 +551,7 @@ module Aws::AppSync
550
551
# resp.graphql_api.authentication_type #=> String, one of "API_KEY", "AWS_IAM", "AMAZON_COGNITO_USER_POOLS", "OPENID_CONNECT"
551
552
# resp.graphql_api.log_config.field_log_level #=> String, one of "NONE", "ERROR", "ALL"
552
553
# resp.graphql_api.log_config.cloud_watch_logs_role_arn #=> String
554
+ # resp.graphql_api.log_config.exclude_verbose_content #=> Boolean
553
555
# resp.graphql_api.user_pool_config.user_pool_id #=> String
554
556
# resp.graphql_api.user_pool_config.aws_region #=> String
555
557
# resp.graphql_api.user_pool_config.default_action #=> String, one of "ALLOW", "DENY"
@@ -980,6 +982,7 @@ module Aws::AppSync
980
982
# resp.graphql_api.authentication_type #=> String, one of "API_KEY", "AWS_IAM", "AMAZON_COGNITO_USER_POOLS", "OPENID_CONNECT"
981
983
# resp.graphql_api.log_config.field_log_level #=> String, one of "NONE", "ERROR", "ALL"
982
984
# resp.graphql_api.log_config.cloud_watch_logs_role_arn #=> String
985
+ # resp.graphql_api.log_config.exclude_verbose_content #=> Boolean
983
986
# resp.graphql_api.user_pool_config.user_pool_id #=> String
984
987
# resp.graphql_api.user_pool_config.aws_region #=> String
985
988
# resp.graphql_api.user_pool_config.default_action #=> String, one of "ALLOW", "DENY"
@@ -1352,6 +1355,7 @@ module Aws::AppSync
1352
1355
# resp.graphql_apis[0].authentication_type #=> String, one of "API_KEY", "AWS_IAM", "AMAZON_COGNITO_USER_POOLS", "OPENID_CONNECT"
1353
1356
# resp.graphql_apis[0].log_config.field_log_level #=> String, one of "NONE", "ERROR", "ALL"
1354
1357
# resp.graphql_apis[0].log_config.cloud_watch_logs_role_arn #=> String
1358
+ # resp.graphql_apis[0].log_config.exclude_verbose_content #=> Boolean
1355
1359
# resp.graphql_apis[0].user_pool_config.user_pool_id #=> String
1356
1360
# resp.graphql_apis[0].user_pool_config.aws_region #=> String
1357
1361
# resp.graphql_apis[0].user_pool_config.default_action #=> String, one of "ALLOW", "DENY"
@@ -1914,6 +1918,7 @@ module Aws::AppSync
1914
1918
# log_config: {
1915
1919
# field_log_level: "NONE", # required, accepts NONE, ERROR, ALL
1916
1920
# cloud_watch_logs_role_arn: "String", # required
1921
+ # exclude_verbose_content: false,
1917
1922
# },
1918
1923
# authentication_type: "API_KEY", # accepts API_KEY, AWS_IAM, AMAZON_COGNITO_USER_POOLS, OPENID_CONNECT
1919
1924
# user_pool_config: {
@@ -1953,6 +1958,7 @@ module Aws::AppSync
1953
1958
# resp.graphql_api.authentication_type #=> String, one of "API_KEY", "AWS_IAM", "AMAZON_COGNITO_USER_POOLS", "OPENID_CONNECT"
1954
1959
# resp.graphql_api.log_config.field_log_level #=> String, one of "NONE", "ERROR", "ALL"
1955
1960
# resp.graphql_api.log_config.cloud_watch_logs_role_arn #=> String
1961
+ # resp.graphql_api.log_config.exclude_verbose_content #=> Boolean
1956
1962
# resp.graphql_api.user_pool_config.user_pool_id #=> String
1957
1963
# resp.graphql_api.user_pool_config.aws_region #=> String
1958
1964
# resp.graphql_api.user_pool_config.default_action #=> String, one of "ALLOW", "DENY"
@@ -2117,7 +2123,7 @@ module Aws::AppSync
2117
2123
params: params,
2118
2124
config: config)
2119
2125
context[:gem_name] = 'aws-sdk-appsync'
2120
- context[:gem_version] = '1.19.0'
2126
+ context[:gem_version] = '1.20.0'
2121
2127
Seahorse::Client::Request.new(handlers, context)
2122
2128
end
2123
2129
data/lib/aws-sdk-appsync/client_api.rb CHANGED
@@ -491,6 +491,7 @@ module Aws::AppSync
491
491
492
492
LogConfig.add_member(:field_log_level, Shapes::ShapeRef.new(shape: FieldLogLevel, required: true, location_name: "fieldLogLevel"))
493
493
LogConfig.add_member(:cloud_watch_logs_role_arn, Shapes::ShapeRef.new(shape: String, required: true, location_name: "cloudWatchLogsRoleArn"))
494
+ LogConfig.add_member(:exclude_verbose_content, Shapes::ShapeRef.new(shape: Boolean, location_name: "excludeVerboseContent"))
494
495
LogConfig.struct_class = Types::LogConfig
495
496
496
497
MapOfStringToString.key = Shapes::ShapeRef.new(shape: String)
data/lib/aws-sdk-appsync/types.rb CHANGED
@@ -511,6 +511,7 @@ module Aws::AppSync
511
511
# log_config: {
512
512
# field_log_level: "NONE", # required, accepts NONE, ERROR, ALL
513
513
# cloud_watch_logs_role_arn: "String", # required
514
+ # exclude_verbose_content: false,
514
515
# },
515
516
# authentication_type: "API_KEY", # required, accepts API_KEY, AWS_IAM, AMAZON_COGNITO_USER_POOLS, OPENID_CONNECT
516
517
# user_pool_config: {
@@ -1898,6 +1899,7 @@ module Aws::AppSync
1898
1899
# {
1899
1900
# field_log_level: "NONE", # required, accepts NONE, ERROR, ALL
1900
1901
# cloud_watch_logs_role_arn: "String", # required
1902
+ # exclude_verbose_content: false,
1901
1903
# }
1902
1904
#
1903
1905
# @!attribute [rw] field_log_level
@@ -1929,11 +1931,18 @@ module Aws::AppSync
1929
1931
# CloudWatch logs in your account.
1930
1932
# @return [String]
1931
1933
#
1934
+ # @!attribute [rw] exclude_verbose_content
1935
+ # Set to TRUE to exclude sections that contain information such as
1936
+ # headers, context, and evaluated mapping templates, regardless of
1937
+ # logging level.
1938
+ # @return [Boolean]
1939
+ #
1932
1940
# @see http://docs.aws.amazon.com/goto/WebAPI/appsync-2017-07-25/LogConfig AWS API Documentation
1933
1941
#
1934
1942
class LogConfig < Struct.new(
1935
1943
:field_log_level,
1936
- :cloud_watch_logs_role_arn)
1944
+ :cloud_watch_logs_role_arn,
1945
+ :exclude_verbose_content)
1937
1946
include Aws::Structure
1938
1947
end
1939
1948
@@ -2534,6 +2543,7 @@ module Aws::AppSync
2534
2543
# log_config: {
2535
2544
# field_log_level: "NONE", # required, accepts NONE, ERROR, ALL
2536
2545
# cloud_watch_logs_role_arn: "String", # required
2546
+ # exclude_verbose_content: false,
2537
2547
# },
2538
2548
# authentication_type: "API_KEY", # accepts API_KEY, AWS_IAM, AMAZON_COGNITO_USER_POOLS, OPENID_CONNECT
2539
2549
# user_pool_config: {
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: aws-sdk-appsync
3
3
version: !ruby/object:Gem::Version
4
- version: 1.19.0
4
+ version: 1.20.0
5
5
platform: ruby
6
6
authors:
7
7
- Amazon Web Services
8
8
autorequire:
9
9
bindir: bin
10
10
cert_chain: []
11
- date: 2019-07-25 00:00:00.000000000 Z
11
+ date: 2019-08-13 00:00:00.000000000 Z
12
12
dependencies:
13
13
- !ruby/object:Gem::Dependency
14
14
name: aws-sdk-core