checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 875752ec80bea3a12cdac3f2a3424f777fc0bcf4a94b6c28a5f1c4f98e5a6e34
4
- data.tar.gz: ce5f8b2cb550ad0d1a5495ae622152119dc4253dd045fa348fa6921a88751691
3
+ metadata.gz: ec1302e6c87545200be1aafc619be2179f680ba24cbfa80b7876cbb66062411b
4
+ data.tar.gz: ef2806fab92a090ee0524a855b6ece6960a349ec5952e7c4e76feb3b4c3f0469
5
5
SHA512:
6
- metadata.gz: 8b629b1c487b02b054885db26d4e49b97ed652cda40cb4d53e11d25cca170d8d0d876619b13df307cb0a19290d9f7447196dc4f24b5c7962edfad26092a194ff
7
- data.tar.gz: 37241c50fc18e27b16fb2c4a2c7eb10ec611b163a046c92cca128a95ca9127950e0e739ddc5ff468890cc40da59bca2d569c04b1d7a8cfac7c24d3baba6fcc86
6
+ metadata.gz: 9016f340db67e2c4a05a3ec3f13d57cc104c4354980c5f09111bc70b1c9cecd778e108998482e8b049c8a356490bb5170f27583554fd910216385d8847425408
7
+ data.tar.gz: 23dd222a388b24c3d01ef0c27004ef3478ec8e7c9f82bf1462ae07ec3f027ac333df69d602c1259295f57f2f6d0a8314f918f7b38e6e754053725df6c67fcf9e
data/app/controllers/tramway/api/application_controller.rb CHANGED
@@ -25,7 +25,7 @@ module Tramway
25
25
if entity.respond_to? :to_token_payload
26
26
::Knock::AuthToken.new payload: entity.to_token_payload
27
27
else
28
- ::Knock::AuthToken.new payload: { sub: entity.id }
28
+ ::Knock::AuthToken.new payload: { sub: entity.uid }
29
29
end
30
30
end
31
31
data/lib/tramway/api/version.rb CHANGED
@@ -1,5 +1,5 @@
1
1
module Tramway
2
2
module Api
3
- VERSION = '1.4'
3
+ VERSION = '1.4.1'
4
4
end
5
5
end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: tramway-api
3
3
version: !ruby/object:Gem::Version
4
- version: '1.4'
4
+ version: 1.4.1
5
5
platform: ruby
6
6
authors:
7
7
- Pavel Kalashnikov