checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 9104c94aa76173b5aaa26efb5577358bfb57e8fcc5fafeb7f044d413a01af40e
4
- data.tar.gz: 03156dd1bba125b360eef9dcf311b9fd9791fc08e0e4aefe092169eface776c8
3
+ metadata.gz: 7cfa88e79b566cff87e814f8af69380dc2473fa7ca9e66c443fe6cde1d30e824
4
+ data.tar.gz: 11be01521bd7d5f5db73db1ad702bf198527c479d6a7e3bcde57139dc50763e8
5
5
SHA512:
6
- metadata.gz: 5c77a6c4c3866b0ad92a1ad31097d92b80dbfca091c617986e9bb27909bb8accd891bf79d3af38f79ac25ffeea33b46ed7fab2f9b707cbbb78d9ccb5e319404f
7
- data.tar.gz: bd04da0ef51a21c19c55dbc6fc7a88252b2be8e28f9afc3fdf19592ea19484c8da242f1312f0f4b1759d6de0af62a3fcab8f2733bd0737ae70f80b285dec3d8d
6
+ metadata.gz: 9fe457d52d7509efbb253bbd76e89948502a3cdae387d870e491a2d4fe42f72626d590de9e69bac3aa298209dfd05de07efb34e8b07db48d26498c4dcb441769
7
+ data.tar.gz: 96f098e039d385bceebacca23dbf8a87ba9e05351e973df11919cfc15c21dcc40d8bf39da4e96c2e4151d5df78dd64f26b776d47b6086d648ab245ff8b39dbf1
data/.travis.yml CHANGED
@@ -1,16 +1,21 @@
1
1
language: ruby
2
2
rvm:
3
3
- 2.4.1
4
+ addons:
5
+ code_climate:
6
+ repo_token: "$CODECLIMATE_REPO_TOKEN"
4
7
install:
5
8
- travis_retry bundle install
6
- script: bundle exec rspec
7
- notifications:
8
- slack: datacite:Wt8En0ALoTA6Kjc5EOKNDWxN
9
+ script:
10
+ - bundle exec rspec
11
+ - bundle exec codeclimate-test-reporter
9
12
deploy:
10
13
provider: rubygems
11
14
api_key:
12
- secure: uE7wQ63qRd3hnuzi2omMNoAcJJfQ/UQqk67qw2llQVYMbQlwgD6nnF5ipkPuqdAxPKZycUoZuD/uFKGK1B5pSPZeMTfFmTls3vPj6kLWeUCNZkZXfOsPPzhipRmxMbuxaCn6IqNtkTavsjC5xkOeBDw9aRTMRphyrwewWtk83NlwpRefNVx1SxU6IAxpySEWpjQ/PsLvJ+NmQuPl6KXlTooDPpaVHaaW9IDLtFoTK4GGWLGiDYWkhwQerUvczxvyuNGr/o0j8obCKau6lgv8eAj1f9W8pXmbvxq8Opp3/8chSvT98sO+L5RwigJYu6X7B1xVZGSNAuOVzNRagGkF2LE20b4p+1RqpmqCLViZcfPXRuSLPD4QlyRqjPbuma1mSQ/7zR8JTyobDJfyrQbuJNu+q96Edf4ZzHATDWik6sWRaU3Qcv5MN3NKgSwB0jbHgdgUeSKZusN4vkpNN4n1uxXnII/7A2b7W9U8wPFqmwhopB9egOxP9BQERFu4GxtI1TOPjIlh3tKy8SjSF0KnunHbaI1s6UrpjEh+mS5k9WryJtRmINFRI+ZHeCI6Sl5sXococnczDImG2AH7PEJ1zZ3rq/JH7J4HJ2moJW6xhvqVhoI1i9ti1VRqDE82GwRb0QE88eS2DZX2/b6J1faxlGuj1Cup+xzOrLnj9pctZLc=
15
+ secure: lEUHxqrw71LBPWKy8PS9EriAFwbeNDsopIkEX1ssU2FbZSMCiE4p4AYC+C+KjmoJ7mNjz+0jtqEIfVgKT93CpP6AqRGG3uxHBXhslyuEFe/ej+QrMb+gzIDZIA3leW0IgPhi7Rtk24RssPmtFAs0wAMM3iOS8lOPpqO5kWGmWMExezcpiVxPld2KIZksLUvwflyOs9aG1+n0Zt5FNyrXKI3W9rK3BytwnPZn2f4ahc8IP5u5jjhnM0tvG697SNQm/GKGkOcQ3iJgZ7RpakosHvocrTGUH+q1FZBpqG2FDKn0HygpQCs30puEIqAlnCBxDoI53G/xjP6CaNr7JCLBYjUMJZ91nJvwHaMfA3nnDEEI3p+MrsV3lwAyvpXQxJeWt3hM1bHcH2pIql2hGMlx6f5XnPCvFaUQwN1Fi534xVCBOSEXCr2G9oStOpW5SA/U7jvohUiCZhIK7eSR5i4w1EbCsU9nQWZYjvX0EprYoVlBqgLGZEKK02JCIwGXPLVYfJwzNBv0uBtiNBkwO8jHVaAEVrJL4Ka8TBy/V3B86mZ+W5EvP6kn6lJCh8Sh7bwpj0NXKllRw2sSz9ukybayLan/OcSgj98LgRKJ09iydxwsTFIVD4kzuGidF+qtT6ImLgD4qWMr4mgCSlsJp83fOzpdzDVLlz+T3tSVB42tNjE=
13
16
gem: omniauth-globus
14
17
on:
15
18
tags: true
16
19
repo: datacite/omniauth-globus
20
+ notifications:
21
+ slack: datacite:Wt8En0ALoTA6Kjc5EOKNDWxN
data/Gemfile.lock CHANGED
@@ -1,8 +1,8 @@
1
1
PATH
2
2
remote: .
3
3
specs:
4
- omniauth-globus (0.8.3)
5
- jwt (>= 2.0)
4
+ omniauth-globus (0.8.7)
5
+ jwt (~> 2.0)
6
6
omniauth (~> 1.9)
7
7
omniauth-oauth2 (~> 1.6)
8
8
@@ -86,12 +86,12 @@ PLATFORMS
86
86
87
87
DEPENDENCIES
88
88
bundler (~> 1.0)
89
- codeclimate-test-reporter (~> 1.0.0)
89
+ codeclimate-test-reporter (~> 1.0, >= 1.0.9)
90
90
omniauth-globus!
91
91
rack-test (~> 0.6.3)
92
92
rspec (~> 3.4)
93
93
rubocop (~> 0.68)
94
- simplecov
94
+ simplecov (~> 0.13.0)
95
95
webmock (~> 3.0, >= 3.0.1)
96
96
97
97
BUNDLED WITH
data/README.md CHANGED
@@ -1,3 +1,67 @@
1
1
# omniauth-globus
2
2
3
- Globus Auth Strategy for OmniAuth
3
+ [![Gem Version](https://badge.fury.io/rb/omniauth-globus.svg)](https://badge.fury.io/rb/omniauth-globus)
4
+ [![Build Status](https://travis-ci.com/datacite/omniauth-globus.svg?branch=master)](https://travis-ci.com/datacite/omniauth-globus)
5
+ [![Test Coverage](https://api.codeclimate.com/v1/badges/13f9467872e9a688e9cb/test_coverage)](https://codeclimate.com/github/datacite/omniauth-globus/test_coverage)
6
+ [![Maintainability](https://api.codeclimate.com/v1/badges/13f9467872e9a688e9cb/maintainability)](https://codeclimate.com/github/datacite/omniauth-globus/maintainability)
7
+
8
+ Globus OAuth 2.0 Strategy for the [OmniAuth Ruby authentication framework](http://www.omniauth.org), with support for OpenID Connect.
9
+
10
+ Provides basic support for authenticating a client application via the [Globus service](http://globus.org).
11
+
12
+ ## Installation
13
+
14
+ The usual way with Bundler: add the following to your `Gemfile` to install the current version of the gem:
15
+
16
+ ```ruby
17
+ gem 'omniauth-globus'
18
+ ```
19
+
20
+ Then run `bundle install` to install into your environment.
21
+
22
+ You can also install the gem system-wide in the usual way:
23
+
24
+ ```bash
25
+ gem install omniauth-globus
26
+ ```
27
+
28
+ ## Getting started
29
+
30
+ Like other OmniAuth strategies, `OmniAuth::Strategies::Globus` is a piece of Rack middleware. Please read the OmniAuth documentation for detailed instructions: https://github.com/intridea/omniauth.
31
+
32
+ Register a client application with Globus [here](https://developers.globus.org/).
33
+
34
+ You can then configure your client application using Omniauth or [Devise](https://github.com/plataformatec/devise) and the credentials obtained from Globus:
35
+
36
+ ```ruby
37
+ use OmniAuth::Builder do
38
+ provider :globus, ENV['GLOBUS_CLIENT_ID'], ENV['GLOBUS_CLIENT_SECRET']
39
+ end
40
+ ```
41
+
42
+ ```ruby
43
+ # in config/initializers/devise.rb
44
+ config.omniauth :globus, ENV["GLOBUS_CLIENT_ID"],
45
+ ENV["GLOBUS_CLIENT_SECRET"]
46
+ ```
47
+
48
+ ## Development
49
+
50
+ We use rspec for unit testing:
51
+
52
+ ```
53
+ bundle exec rspec
54
+ ```
55
+
56
+ Follow along via [Github Issues](https://github.com/datacite/omniauth-globus/issues).
57
+
58
+ ### Note on Patches/Pull Requests
59
+
60
+ * Fork the project
61
+ * Write tests for your new feature or a test that reproduces a bug
62
+ * Implement your feature or make a bug fix
63
+ * Do not mess with Rakefile, version or history
64
+ * Commit, push and make a pull request. Bonus points for topical branches.
65
+
66
+ ## License
67
+ **omniauth-globus** is released under the [MIT License](https://github.com/datacite/omniauth-orcid/blob/master/LICENSE.md).
data/lib/omniauth/globus/version.rb CHANGED
@@ -2,6 +2,6 @@
2
2
3
3
module OmniAuth
4
4
module Globus
5
- VERSION = "0.8.3"
5
+ VERSION = "0.8.7"
6
6
end
7
7
end
data/omniauth-globus.gemspec CHANGED
@@ -8,9 +8,9 @@ Gem::Specification.new do |s|
8
8
s.email = ["mfenner@datacite.org"]
9
9
s.name = "omniauth-globus"
10
10
s.homepage = "https://github.com/datacite/omniauth-globus"
11
- s.summary = "Globus Auth OpenId connect Strategy for OmniAuth 1.0"
11
+ s.summary = "Globus OpenId connect Strategy for OmniAuth 1.0"
12
12
s.date = Date.today
13
- s.description = "Enables third-party client apps to authenticate with the Globus Auth service via OpenID Connect"
13
+ s.description = "Enables third-party client apps to authenticate with the Globus service via OpenID Connect"
14
14
s.require_paths = ["lib"]
15
15
s.version = OmniAuth::Globus::VERSION
16
16
s.extra_rdoc_files = ["README.md"]
@@ -22,14 +22,14 @@ Gem::Specification.new do |s|
22
22
s.required_ruby_version = ">= 2.3"
23
23
24
24
# Declary dependencies here, rather than in the Gemfile
25
- s.add_dependency "jwt", ">= 2.0"
25
+ s.add_dependency "jwt", "~> 2.0"
26
26
s.add_dependency "omniauth", "~> 1.9"
27
27
s.add_dependency "omniauth-oauth2", "~> 1.6"
28
28
s.add_development_dependency "bundler", "~> 1.0"
29
- s.add_development_dependency "codeclimate-test-reporter", "~> 1.0.0"
29
+ s.add_development_dependency "codeclimate-test-reporter", "~> 1.0", ">= 1.0.9"
30
30
s.add_development_dependency "rack-test", "~> 0.6.3"
31
31
s.add_development_dependency "rspec", "~> 3.4"
32
32
s.add_development_dependency "rubocop", "~> 0.68"
33
- s.add_development_dependency "simplecov"
33
+ s.add_development_dependency "simplecov", "~> 0.13.0"
34
34
s.add_development_dependency "webmock", "~> 3.0", ">= 3.0.1"
35
35
end
metadata CHANGED
@@ -1,7 +1,7 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: omniauth-globus
3
3
version: !ruby/object:Gem::Version
4
- version: 0.8.3
4
+ version: 0.8.7
5
5
platform: ruby
6
6
authors:
7
7
- Martin Fenner
@@ -14,14 +14,14 @@ dependencies:
14
14
name: jwt
15
15
requirement: !ruby/object:Gem::Requirement
16
16
requirements:
17
- - - ">="
17
+ - - "~>"
18
18
- !ruby/object:Gem::Version
19
19
version: '2.0'
20
20
type: :runtime
21
21
prerelease: false
22
22
version_requirements: !ruby/object:Gem::Requirement
23
23
requirements:
24
- - - ">="
24
+ - - "~>"
25
25
- !ruby/object:Gem::Version
26
26
version: '2.0'
27
27
- !ruby/object:Gem::Dependency
@@ -72,14 +72,20 @@ dependencies:
72
72
requirements:
73
73
- - "~>"
74
74
- !ruby/object:Gem::Version
75
- version: 1.0.0
75
+ version: '1.0'
76
+ - - ">="
77
+ - !ruby/object:Gem::Version
78
+ version: 1.0.9
76
79
type: :development
77
80
prerelease: false
78
81
version_requirements: !ruby/object:Gem::Requirement
79
82
requirements:
80
83
- - "~>"
81
84
- !ruby/object:Gem::Version
82
- version: 1.0.0
85
+ version: '1.0'
86
+ - - ">="
87
+ - !ruby/object:Gem::Version
88
+ version: 1.0.9
83
89
- !ruby/object:Gem::Dependency
84
90
name: rack-test
85
91
requirement: !ruby/object:Gem::Requirement
@@ -126,16 +132,16 @@ dependencies:
126
132
name: simplecov
127
133
requirement: !ruby/object:Gem::Requirement
128
134
requirements:
129
- - - ">="
135
+ - - "~>"
130
136
- !ruby/object:Gem::Version
131
- version: '0'
137
+ version: 0.13.0
132
138
type: :development
133
139
prerelease: false
134
140
version_requirements: !ruby/object:Gem::Requirement
135
141
requirements:
136
- - - ">="
142
+ - - "~>"
137
143
- !ruby/object:Gem::Version
138
- version: '0'
144
+ version: 0.13.0
139
145
- !ruby/object:Gem::Dependency
140
146
name: webmock
141
147
requirement: !ruby/object:Gem::Requirement
@@ -156,8 +162,8 @@ dependencies:
156
162
- - ">="
157
163
- !ruby/object:Gem::Version
158
164
version: 3.0.1
159
- description: Enables third-party client apps to authenticate with the Globus Auth
160
- service via OpenID Connect
165
+ description: Enables third-party client apps to authenticate with the Globus service
166
+ via OpenID Connect
161
167
email:
162
168
- mfenner@datacite.org
163
169
executables: []
@@ -204,7 +210,7 @@ requirements: []
204
210
rubygems_version: 3.0.1
205
211
signing_key:
206
212
specification_version: 4
207
- summary: Globus Auth OpenId connect Strategy for OmniAuth 1.0
213
+ summary: Globus OpenId connect Strategy for OmniAuth 1.0
208
214
test_files:
209
215
- spec/fixtures/access_token.json
210
216
- spec/fixtures/request_info.json