checksums.yaml CHANGED
@@ -1,7 +1,7 @@
1
1
---
2
2
SHA256:
3
- metadata.gz: 733a865e389fa047b8103d8fc0812c48e0319afe8e011ef74db0919279390745
4
- data.tar.gz: b9e9f63711084d7b71faa7954d65c316b6c15274b3db58ca306b7187a83b64b8
3
+ metadata.gz: f4853766800037717bd572948579007955772f431af5ced43bccf24b8ce70d2f
4
+ data.tar.gz: f798d126cbe029c9218030b0056a68ee115ecb6c3a3803ae919fe9ccc654498f
5
5
SHA512:
6
- metadata.gz: 482983bf3887f114a81004fc3a1ebf98b81d1808298cdab8f3315a0865a62a14e694ca979482aad38d1b4a860ca07991df7f63f2d07b4fca2b1312234467d225
7
- data.tar.gz: 6e4713905ba7263a2e0138a11ae7de941fd3965aaf51f426ce0e3b027a932ba5c0f37712cd07cf30aee3168d01f7c46240fd2edf54c94dc3668a1245e96aec0e
6
+ metadata.gz: 65a1fe285c944fa67d8737efb2b328267c6d7d60dbc46dbbb02191369cb7fed0cee0fb416d9476707d7d035dbdee49a0ceddeab51b4ba1ab7499740ba2d7a3a3
7
+ data.tar.gz: 3f41cbf4d255c8d3e5d30882ab95301fb14f58d30a24105f4ed4ca4f324d075e40bc73ba222ec3d647584d439f0b62df0a7d8a13c1bcbd6e26914d2a56d1d664
data/.travis.yml CHANGED
@@ -20,6 +20,5 @@ script:
20
20
- awesome_bot -f bin/assets/test-no-issues,bin/assets/test-redirect --allow-redirect
21
21
- awesome_bot bin/assets/test-no-* --allow-redirect
22
22
- awesome_bot bin/assets/test-ssl --allow-ssl
23
- - awesome_bot bin/assets/test-request-delay -d 1
24
23
- awesome_bot README.md --allow-dupe --white-list gph.is,giphy,travis-ci.org,codeload,badge,rubydoc,rubygems,circleci,codeship,blob/master
25
24
- gem install awesome_bot
data/CHANGELOG.md CHANGED
@@ -2,6 +2,10 @@
2
2
3
3
Changes by [Daniel Khamsing][] unless otherwise noted.
4
4
5
+ # 1.19.1
6
+
7
+ - [gem] update `parallel`, `rspec`, `rspec_junit_formatter` to latest
8
+
5
9
# 1.19.0
6
10
7
11
- [parse] handle javadoc links by [Davide Angelocola](https://github.com/dfa1)
data/Gemfile CHANGED
@@ -1,5 +1,5 @@
1
1
source 'https://rubygems.org'
2
2
3
3
gemspec
4
- gem 'rspec_junit_formatter', '0.2.3' # test meta data / ci
5
- gem 'rspec', '3.6.0' # tests'
4
+ gem 'rspec_junit_formatter', '0.4.1' # test meta data / ci
5
+ gem 'rspec', '3.8.0' # tests'
data/awesome_bot.gemspec CHANGED
@@ -21,6 +21,5 @@ Gem::Specification.new do |spec|
21
21
22
22
spec.required_ruby_version = '>= 2.0.0'
23
23
24
- spec.add_runtime_dependency 'parallel', '1.12.0' # threading
24
+ spec.add_runtime_dependency 'parallel', '1.17.0' # threading
25
25
end
26
-
data/bin/assets/test-request-delay DELETED
@@ -1,50 +0,0 @@
1
- 01. https://chan.sankakucomplex.com/post/show/82338
2
- 02. https://chan.sankakucomplex.com/post/show/828541
3
- 03. https://chan.sankakucomplex.com/post/show/847569
4
- 04. https://chan.sankakucomplex.com/post/show/859296
5
- 05. https://chan.sankakucomplex.com/post/show/945883
6
- 06. https://chan.sankakucomplex.com/post/show/947875
7
- 07. https://chan.sankakucomplex.com/post/show/949241
8
- 08. https://chan.sankakucomplex.com/post/show/965668
9
- 09. https://chan.sankakucomplex.com/post/show/992332
10
- 10. https://chan.sankakucomplex.com/post/show/998051
11
- 11. https://chan.sankakucomplex.com/post/show/82323
12
- 12. https://chan.sankakucomplex.com/post/show/82841
13
- 13. https://chan.sankakucomplex.com/post/show/84769
14
- 14. https://chan.sankakucomplex.com/post/show/829296
15
- 15. https://chan.sankakucomplex.com/post/show/925883
16
- 16. https://chan.sankakucomplex.com/post/show/927875
17
- 17. https://chan.sankakucomplex.com/post/show/929241
18
- 18. https://chan.sankakucomplex.com/post/show/925668
19
- 19. https://chan.sankakucomplex.com/post/show/922332
20
- 20. https://chan.sankakucomplex.com/post/show/928051
21
- 21. https://chan.sankakucomplex.com/post/show/8233
22
- 22. https://chan.sankakucomplex.com/post/show/8285
23
- 23. https://chan.sankakucomplex.com/post/show/8475
24
- 24. https://chan.sankakucomplex.com/post/show/8592
25
- 25. https://chan.sankakucomplex.com/post/show/9458
26
- 26. https://chan.sankakucomplex.com/post/show/9478
27
- 27. https://chan.sankakucomplex.com/post/show/9492
28
- 28. https://chan.sankakucomplex.com/post/show/9656
29
- 29. https://chan.sankakucomplex.com/post/show/9923
30
- 30. https://chan.sankakucomplex.com/post/show/9980
31
- 31. https://chan.sankakucomplex.com/post/show/8281
32
- 32. https://chan.sankakucomplex.com/post/show/8542
33
- 33. https://chan.sankakucomplex.com/post/show/847562
34
- 34. https://chan.sankakucomplex.com/post/show/85992
35
- 35. https://chan.sankakucomplex.com/post/show/9482
36
- 36. https://chan.sankakucomplex.com/post/show/9472
37
- 37. https://chan.sankakucomplex.com/post/show/949242
38
- 38. https://chan.sankakucomplex.com/post/show/96562
39
- 39. https://chan.sankakucomplex.com/post/show/992333
40
- 40. https://chan.sankakucomplex.com/post/show/9053
41
- 41. https://chan.sankakucomplex.com/post/show/82138
42
- 42. https://chan.sankakucomplex.com/post/show/821541
43
- 43. https://chan.sankakucomplex.com/post/show/841569
44
- 44. https://chan.sankakucomplex.com/post/show/851296
45
- 45. https://chan.sankakucomplex.com/post/show/941883
46
- 46. https://chan.sankakucomplex.com/post/show/941875
47
- 47. https://chan.sankakucomplex.com/post/show/941241
48
- 48. https://chan.sankakucomplex.com/post/show/961668
49
- 49. https://chan.sankakucomplex.com/post/show/991332
50
- 50. https://chan.sankakucomplex.com/post/show/991051
data/lib/awesome_bot/version.rb CHANGED
@@ -5,5 +5,5 @@ module AwesomeBot
5
5
'Great for "awesome" projects.'
6
6
PROJECT_URL = 'https://github.com/dkhamsing/awesome_bot'
7
7
8
- VERSION = '1.19.0'
8
+ VERSION = '1.19.1'
9
9
end
metadata CHANGED
@@ -1,14 +1,14 @@
1
1
--- !ruby/object:Gem::Specification
2
2
name: awesome_bot
3
3
version: !ruby/object:Gem::Version
4
- version: 1.19.0
4
+ version: 1.19.1
5
5
platform: ruby
6
6
authors:
7
7
- Daniel Khamsing
8
8
autorequire:
9
9
bindir: bin
10
10
cert_chain: []
11
- date: 2019-08-13 00:00:00.000000000 Z
11
+ date: 2019-08-16 00:00:00.000000000 Z
12
12
dependencies:
13
13
- !ruby/object:Gem::Dependency
14
14
name: parallel
@@ -16,14 +16,14 @@ dependencies:
16
16
requirements:
17
17
- - '='
18
18
- !ruby/object:Gem::Version
19
- version: 1.12.0
19
+ version: 1.17.0
20
20
type: :runtime
21
21
prerelease: false
22
22
version_requirements: !ruby/object:Gem::Requirement
23
23
requirements:
24
24
- - '='
25
25
- !ruby/object:Gem::Version
26
- version: 1.12.0
26
+ version: 1.17.0
27
27
description: Check for valid and duplicate URLs in a file. Great for "awesome" projects.
28
28
email:
29
29
- dkhamsing8@gmail.com
@@ -52,7 +52,6 @@ files:
52
52
- bin/assets/test-no-links
53
53
- bin/assets/test-parse
54
54
- bin/assets/test-redirect
55
- - bin/assets/test-request-delay
56
55
- bin/assets/test-ssl
57
56
- bin/assets/test-statuses
58
57
- bin/assets/test-timeout